当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Dapper中使用SimSun字体,字体渲染出问题,有些字随机糊了
帖子发表于 : 2006-03-20 21:19 

注册: 2006-02-27 18:06
帖子: 80
地址: FZU
送出感谢: 0 次
接收感谢: 0 次
不知道大家有没碰到过这样的清况:

1. copy Windows的中文字体到 /usr/local/share/fonts/truetype/microsoft下(我用笔记本带的正版windows,拷到同一台机器的linux下,应该可以吧:)

2. 执行 fc-cache -fv ,另外在 fonts.conf中关闭simsun在9-12pt的抗锯齿

3. 将系统主要字体更新为simsun,在FireFox中将简体中文的sans-setif字体替换成simsun。

这时打开一个网页,比如sina,驱动之家,可以看到有些地方的中文字糊掉了。
情况不管发生在firefox中,程序界面也有,不过网页上的字比较多,出现几率高。参看附件图片标注的地方。

图片

后来将点阵字体的抗锯齿打开,就没糊了,真是奇怪啊。。。

我已更新到3月20号最新的fontconfig了。。。用默认的fonts.conf还是一样。


附件:
Screenshot-新浪首页 - Mozilla Firefox.png
Screenshot-新浪首页 - Mozilla Firefox.png [ 55.83 KiB | 被浏览 504 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-03-20 21:28 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
还没有修改fonts.conf。
这不是simsun.


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-03-20 21:38 

注册: 2006-02-27 18:06
帖子: 80
地址: FZU
送出感谢: 0 次
接收感谢: 0 次
是simsun.ttc,截图的时候我都还没删掉/etc/fonts/conf.d/30-deb-nobitmap,肯定不是wqy,而且我把文鼎的都删光了。Firefox中也是直接选择simsun,不是Sans之类的字体类

默认fonts.conf中已经把simsun加入了,其实选Sans多半也是用simsun渲染中文,因为我机上没有其他中文字体了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-03-21 11:37 

注册: 2005-04-09 8:55
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
把 /etc/X11/xorg.conf 里的 Option "RenderAccel" "true" 改成
Option "RenderAccel" "false",或者删除。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-03-21 20:40 

注册: 2006-02-27 18:06
帖子: 80
地址: FZU
送出感谢: 0 次
接收感谢: 0 次
china 写道:
把 /etc/X11/xorg.conf 里的 Option "RenderAccel" "true" 改成
Option "RenderAccel" "false",或者删除。


兄弟你真强,试了试关闭后果然好了。
用的是nv 6800Go显卡,81.78驱动,前一阵用XGL时开启RenderAccel的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译