eth0的问题,不知道怎么办了~~

为当前最终发行版之前的所有版本提供支持
回复
jackcly
帖子: 28
注册时间: 2005-09-11 20:30
送出感谢: 0
接收感谢: 0

eth0的问题,不知道怎么办了~~

#1

帖子 jackcly » 2006-03-21 14:54

先说下情况吧,eth0开机不能自动激活,
输入ifconfig命令什么也没有

输入 sudo /etc/init.d/networking restart 提示fail,只能手写ifconfig eth0 ~~~~,
/etc/network/interfaces应该没问题的,还是贴下

大家帮帮我吧

+++++++++++++++++++++++++++++++++++++++++++
/etc/network/interfaces
+++++++++++++++++++++++++++++++++++++++++++
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth0

# The primary network interface

iface eth0 inet static
#iface eth0 inet up
address 10.85.33.234
netmask 255.255.255.0
network 10.85.33.0
broadcast 10.85.33.255
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 202.120.224.6
dns-nameservers 202.96.209.6
route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.85.33.254
route add -net 202.120.0.0 netmask 255.255.0.0 gw 10.85.33.254
route add -net 61.129.42.0 netmask 255.255.255.0 gw 10.85.33.254
route add -net 192.168.0.0 netmask 255.255.0.0 gw 10.85.33.254
iface eth1 inet
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#2

帖子 leal » 2006-03-21 15:59

加一句
auto eth0
用心×恒 | 豆瓣 | 门户 | Blog
jackcly
帖子: 28
注册时间: 2005-09-11 20:30
送出感谢: 0
接收感谢: 0

#3

帖子 jackcly » 2006-03-21 18:14

加在最后了,刚才没贴出来:(。现在加到前面了,重启还是一样的。另外在kde的控制中心里面也不能激活eth0,是不是什么服务被没启用呢?
jackcly
帖子: 28
注册时间: 2005-09-11 20:30
送出感谢: 0
接收感谢: 0

#4

帖子 jackcly » 2006-03-21 18:21

关键是为什么执行 /etc/init.d/networking restart 会 fail,前一段时间还可以上的呢。
motoc650
帖子: 4
注册时间: 2006-03-17 9:17
送出感谢: 0
接收感谢: 0

#5

帖子 motoc650 » 2006-03-27 10:45

你看看是不是kde里边是eth1?
我的X22装5.10的时候网络正常
改为6.04则/etc/network/interfaces里边为eth0,而kde里为eth1
修改interfaces文件后ifconfig eth1 up成功
回复

回到 “老旧版本支持”