疑问:段错误

为当前最终发行版之前的所有版本提供支持
回复
dawnplum
帖子: 6
注册时间: 2006-03-16 11:11
送出感谢: 0
接收感谢: 0

疑问:段错误

#1

帖子 dawnplum » 2006-03-21 15:58

以前在红帽子中正常运行的计算程序,在kubuntu上运行时显示段错误?请问是程序本身的问题还是kubuntu系统的问题?
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 yang119345 » 2006-03-21 16:00

在kubuntu下重新编译运行一下
dawnplum
帖子: 6
注册时间: 2006-03-16 11:11
送出感谢: 0
接收感谢: 0

#3

帖子 dawnplum » 2006-03-21 16:01

编译通过,没有问题,运行时会出现段错误,不知道什么原因。
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#4

帖子 leal » 2006-03-21 16:31

可能没有安装该程序用到的某些库

用strace跟踪一下看看
用心×恒 | 豆瓣 | 门户 | Blog
ahlongxp
帖子: 209
注册时间: 2006-03-06 19:16
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 ahlongxp » 2006-03-25 10:05

我也碰到过,C++写的程序用GCC编译成功后,运行也会有“断错误”
用G++编译就没问题
回复

回到 “老旧版本支持”