way i cant apt-get install software before apt-get update?

为当前最终发行版之前的所有版本提供支持
回复
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

way i cant apt-get install software before apt-get update?

#1

帖子 joe45 » 2006-03-22 0:52

way i cant use apt-get to install software, before apt-get update?
I am under firewall, so i must use export http_proxy=http:xxx.xx.xx.xx:xx to apt-get update, but the server very slow, i want install some software first, such as:scim, but i cant use apt-get to download. way?


root@zq:~# export http_proxy=http://172.18.64.222:80
root@zq:~# sudo apt-get install xine-ui
正在读取软件包列表... 有错误!
E: Dynamic MMap ran out of room
E: 处理 libclan2-vorbis (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.org.cn_ubuntu_dists_hoary_universe_binary-i386_Packages
E: 无法解析或打开软件包的列表或是状态文件。
root@zq:~# export http_proxy=http://172.18.64.222:80
root@zq:~# sudo apt-get install scim scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh scim-input-pad
正在读取软件包列表... 有错误!
E: Dynamic MMap ran out of room
E: 处理 libclan2-vorbis (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.org.cn_ubuntu_dists_hoary_universe_binary-i386_Packages
E: 无法解析或打开软件包的列表或是状态文件。
root@zq:~# sudo apt-get install scim
正在读取软件包列表... 有错误!
E: Dynamic MMap ran out of room
E: 处理 libclan2-vorbis (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.org.cn_ubuntu_dists_hoary_universe_binary-i386_Packages
E: 无法解析或打开软件包的列表或是状态文件。

---------------------------------------------------------------------

but i do update can,

root@zq:~# export http_proxy=http://172.18.64.222:80
root@zq:~# sudo apt-get update
获取:1 http://security.ubuntu.com breezy-security Release.gpg [189B]
获取:2 http://archive.ubuntu.org.cn warty Release.gpg [189B]
获取:3 http://security.ubuntu.com breezy-security Release [27.0kB]
获取:4 http://archive.ubuntu.org.cn warty-security Release.gpg [189B]
获取:5 http://archive.ubuntu.org.cn warty-updates Release.gpg [189B]
获取:6 http://archive.ubuntu.org.cn hoary Release.gpg [189B]
获取:7 http://archive.ubuntu.org.cn hoary-security Release.gpg [189B]
获取:8 http://archive.ubuntu.org.cn hoary-updates Release.gpg [189B]
获取:9 http://mirror.lupaworld.com breezy Release.gpg [189B]
获取:10 http://archive.ubuntu.org.cn breezy Release.gpg [189B]
获取:11 http://cn.archive.ubuntu.com breezy Release.gpg [189B]
获取:12 http://mirror.lupaworld.com breezy-security Release.gpg [189B]
获取:13 http://archive.ubuntu.org.cn breezy-security Release.gpg [189B]
获取:14 http://cn.archive.ubuntu.com breezy-updates Release.gpg [189B]
获取:15 http://archive.ubuntu.org.cn breezy-updates Release.gpg [189B]
获取:16 http://cn.archive.ubuntu.com breezy Release [30.9kB]
获取:17 http://ubuntu.cn99.com breezy Release.gpg [189B]
获取:18 http://ubuntu.cn99.com breezy-updates Release.gpg [189B]
获取:19 http://ubuntu.cn99.com breezy-security Release.gpg [189B]
获取:20 http://mirror.lupaworld.com breezy-updates Release.gpg [189B]
获取:21 http://ubuntu.cn99.com breezy-backports Release.gpg [189B]


-----------------------------------------------------

so that mean must do update first right?
and I am doing update can get data, mean the server i can connect right??
thank you!
sorry, dont have chinese input!!!!!!!!!!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-03-22 1:00

update 一次。获得软件列表和下载的位置啊。难道要install到ms的网站取软件。
● 鸣学
joyolee
帖子: 83
注册时间: 2005-12-24 14:07
送出感谢: 0
接收感谢: 0

#3

帖子 joyolee » 2006-03-24 0:39

update相当于获得升级的列表信息,系统可以判断是否需要升级,类似于索引把

upgrade才是真正开始下载文件开始升级
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 firehare » 2006-03-24 14:17

你先 sudo apt-get update 更新软件包信息
然后 sudo apt-get dist-upgrade 升级软件包
最后 sudo apt-get install xxxx 安装软件
我心无畏,源自于我心无知。
图片
回复

回到 “老旧版本支持”