当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题] 添加/删除启动不了,新立德启动是出现错误代码: dpkg --configure -a
帖子发表于 : 2008-04-20 22:18 

注册: 2007-09-24 0:14
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
7.10升级到8.04后添加/删除启动不了,新立德启动是出现错误代码:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

在终端运行后出现:dpkg: 该操作需要超级用户权限

请教如何解决?


我是菜鸟,我不怕问!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-20 22:38 

注册: 2008-02-01 7:16
帖子: 471
送出感谢: 0 次
接收感谢: 0 次
sudo dpkg --configure -a


页首
 用户资料  
 
3 楼 
 文章标题 : 还有错误!
帖子发表于 : 2008-04-21 0:48 

注册: 2007-09-24 0:14
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
在处理时有错误发生:
hal
gnome-mount
gnome-volume-manager
update-notifier
thoggen
ubuntu-desktop
network-manager
network-manager-gnome
gnome-power-manager
sound-juicer
pulseaudio-module-hal
hal-cups-utils
hwdb-client-common
gnome-session
hwdb-client-gnome


页首
 用户资料  
 
4 楼 
 文章标题 : 楼主的情况我也碰到了
帖子发表于 : 2008-04-22 1:40 
头像

注册: 2008-04-18 22:47
帖子: 337
地址: 中国上海
送出感谢: 0 次
接收感谢: 0 次
我是安装java-doc的时候遇到的,从新立得里面安装了之后,java-doc没有安装成功

然后安装别的软件的时候就报错了:和楼主的一模一样

我就执行dpkg --configure -a我就打了
sudo dpkg --configure -a

发现原来java-doc没有下载成功导致不能安装
按enter可以ertry,输入no在按enter可以暂时skip掉
我就是输入了no再按的enter这样下次我再打开新立得的时候就出现了楼主提出的错误。

这样导致了我其他的软件都安装不了了,再仔细看sudo dpkg --configure -a
输入之后的提示信息,让我去sun网站上自己下载java-doc-en.zip的文件或者java-doc-japanese.zip的文件
然后将下载好的文件放到/tmp目录下再sudo dpkg --configure -a就可以了。

我按照这个路子试下来还真的可以了。
java环境也装好了。

楼上的可以参考一下菜鸟的经历


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-22 2:20 

注册: 2007-11-15 7:47
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
现在的LINUX系统真是强大啊,99年那会玩LINUX哪有这么贴心的功能!就报个错,自己想办法去,那时候有没有宽带,更没有现在这么多的LINUX资源,那叫一个累!!!解决点问题心里别提多满足了,哈哈……


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-22 23:20 

注册: 2007-09-24 0:14
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
已经按照指引解决,感谢帮助我的 人!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译