[已解决]7.04升级到7.10出问题了,在线升级的

为当前最终发行版之前的所有版本提供支持
回复
linux2ubuntu
帖子: 78
注册时间: 2007-10-25 11:26
送出感谢: 0
接收感谢: 0
联系:

[已解决]7.04升级到7.10出问题了,在线升级的

#1

帖子 linux2ubuntu » 2008-04-23 13:13

我是从AMD64 7.04升级的,/var/cache/apt/archives 里面下载的都是64位的文件,升级过程出了好几次故障,但最后还是升级好可以用了,进系统时grub显示的是7.10的。但是今天我安装compiz 等软件时出现下列问题,说是软件包体系架构不同,什么都装不好了。{软件包的体系架构(amd64)与本机系统的架构(i386)不符}

现在不知如何办才好。求人指教。

将会安装下列额外的软件包:
python-compizconfig
下列【新】软件包将被安装:
python-compizconfig
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/36.6kB 的软件包。
解压缩后会消耗掉 160kB 的额外空间。
您希望继续执行吗?[Y/n]y
dpkg:处理 /var/cache/apt/archives/python-compizconfig_0.5.2+git20070912-0ubuntu1_amd64.deb (--unpack)时出错:
软件包的体系架构(amd64)与本机系统的架构(i386)不符
在处理时有错误发生:
/var/cache/apt/archives/python-compizconfig_0.5.2+git20070912-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
附件
Screenshot-archives .png
上次由 linux2ubuntu 在 2008-04-23 19:25,总共编辑 1 次。
linux2ubuntu
帖子: 78
注册时间: 2007-10-25 11:26
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 linux2ubuntu » 2008-04-23 14:48

我在升级期间以为DPKG有问题,找了个dpkg换了的,不知是不是这个换成32位的引起的?
linux2ubuntu
帖子: 78
注册时间: 2007-10-25 11:26
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 linux2ubuntu » 2008-04-23 19:25

http://packages.ubuntu.com 找到个64位的dpkg问题解决了。果然是我把版本搞错了。
回复

回到 “老旧版本支持”