breezy升级到dapper后不能进X了

为当前最终发行版之前的所有版本提供支持
回复
nifi
帖子: 335
注册时间: 2005-06-12 12:23
送出感谢: 0
接收感谢: 0
联系:

breezy升级到dapper后不能进X了

#1

帖子 nifi » 2006-03-23 14:34

郁闷啊!
先用breezy的iso进行硬盘安装,完成后将源改成cn99的breezy升级,完成后再改成dapper的,推出X进行升级,升级过程中没有发现什么问题,但之后startx就报出一下的错误,重新配置xserver-xorg 也不行,哪位大哥帮我看看该怎么整,谢谢!
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) No Input driver matching `kbd'
(EE) No Input driver matching `mouse'
(--) Synaptics Touchpad ALPS touchpad found
No core keyboard

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 roylez » 2006-03-23 16:57

把.xsession-errors弄出来看看。
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
nifi
帖子: 335
注册时间: 2005-06-12 12:23
送出感谢: 0
接收感谢: 0
联系:

太长了,直接传上来吧

#3

帖子 nifi » 2006-03-23 20:27

没有压缩,下载后直接把扩展名去掉就行了
帮忙看看吧,谢啦!
附件
xsession-errors.zip
(67.46 KiB) 下载 31 次
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 roylez » 2006-03-23 21:08

好像看不出所以然的样子……
你能确定你的gdm还在吗?有几条错误是说找不到gdm。
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-03-23 22:53

键盘鼠标都提示的,多半是需要

代码: 全选

~$ dpkg-reconfigure --help
用法:dpkg-reconfigure [选项] 软件包
  -a,  --all                    重配置所有软件包。
  -u,  --unseen-only            仅显示未提过的问题。
       --default-priority       使用默认优先级,而非“低”级。
       --force                  强迫重配置受损软件包。
  -f,  --frontend               指定 debconf 前端界面。
  -p,  --priority               指定要显示的问题的最优先级。
       --terse                  开启简要模式。
● 鸣学
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#6

帖子 leal » 2006-03-23 23:03

建议在cosole下

sudo apt-get dist-upgrade -f
试试
用心×恒 | 豆瓣 | 门户 | Blog
nifi
帖子: 335
注册时间: 2005-06-12 12:23
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 nifi » 2006-03-24 11:09

用dpkg查了一下,gdm和xserver-xorg都是ii,应该没有问题
我试着install了一个xdm,改用xdm,提示同样的错误
ddru
帖子: 7
注册时间: 2006-02-20 10:25
送出感谢: 0
接收感谢: 0

我也遇到过同样的问题

#8

帖子 ddru » 2006-03-27 8:58

安装新的的内核包,以及官方内核包相对应的模块包,
apt-get dist-upgrade 之后,应该就能识别了
回复

回到 “老旧版本支持”