有谁成功安装ati驱动拉????

为当前最终发行版之前的所有版本提供支持
回复
shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

有谁成功安装ati驱动拉????

#1

帖子 shitbaby » 2006-03-24 13:22

我的fglrx-6-8-0_8.23.7-2_i386.deb
按照论坛上方法 不能起动x
dsyin
帖子: 116
注册时间: 2006-03-08 22:20
送出感谢: 0
接收感谢: 0

#2

帖子 dsyin » 2006-03-24 14:10

我是用下面的方法成功安装 ati 驱动的
http://www.ubuntu.org.cn/support/docume ... ver-8.18.8
woodwater
帖子: 116
注册时间: 2006-03-06 11:35
来自: 上海
送出感谢: 0
接收感谢: 0

#3

帖子 woodwater » 2006-03-24 14:42

shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

#4

帖子 shitbaby » 2006-03-24 16:47

xorg-driver-fglrx 不能删除
sudo apt-get remove xorg-driver-fglrx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列软件包将被【卸载】:
xorg-driver-fglrx
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 24.1MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 77821 个文件和目录。)
正在删除 xorg-driver-fglrx ...
dpkg-divert: rename involves overwriting `/usr/X11R6/lib/libGL.so.1.2' with
different file `/usr/X11R6/lib/fglrx/libGL.so.1.2.xlibmesa', not allowed
dpkg:处理 xorg-driver-fglrx (--remove)时出错:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
xorg-driver-fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)
shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

#5

帖子 shitbaby » 2006-03-24 18:38

二楼的 你是dapper吗??
yangkwch
帖子: 56
注册时间: 2006-03-25 6:18
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 yangkwch » 2006-03-25 6:44

我是按照论坛上的另一种方法,现在新立得里安装xorg-driver-fglrx,相当于使用 sudo apt-get install xorg-driver-fglrx
然后是:
sudo apt-get instal xorg-driver-fglrx
echo fglrx | sudo tee -a /etc/modules
sudo depmod -a ; sudo modprobe fglrx
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/xorg.conf
然后OK.
dsyin
帖子: 116
注册时间: 2006-03-08 22:20
送出感谢: 0
接收感谢: 0

#7

帖子 dsyin » 2006-03-25 11:32

shitbaby 写了:二楼的 你是dapper吗??
是的
shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

#8

帖子 shitbaby » 2006-03-25 21:25

Installing the driver

sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial


我的问题:joey@ubuntu:~$ sudo apt-get install linux-restricted-modules-386
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
linux-restricted-modules-386 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
joey@ubuntu:~$ sudo apt-get install xorg-driver-fglrx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
xorg-driver-fglrx 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
joey@ubuntu:~$ sudo aticonfig --initial
sudo: aticonfig: command not found
joey@ubuntu:~$



Confirm that it works

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.5695 (8.23.7)


and我的是这样 郁闷。。。。。。。。。。。

joey@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
回复

回到 “老旧版本支持”