dapper无法安装mplayer

为当前最终发行版之前的所有版本提供支持
回复
shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

dapper无法安装mplayer

#1

帖子 shitbaby » 2006-03-25 20:44

sudo apt-get install mplayer-386
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer-386: 依赖: libjack0.80.0-0 (>= 0.99.0) 但是它将不会被安装
E: 无法安装的软件包
joey@ubuntu:~$ sudo apt-get install libjack
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 libjack
joey@ubuntu:~$ sudo apt-get install libjack0.80
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 libjack0.80



自己编译安装老是出错 gcc3.4我也装了 且编译时候指定 --cc=gcc34

也出错拉:
[b]Checking for inet_pton() ... no (=> i'll try inet_aton next)
Checking for inet_aton() ... no (=> network support disabled)
Checking for inttypes.h (required) ... no
Checking for bitypes.h (inttypes.h predecessor) ...
Error: Cannot find header either inttypes.h or bitypes.h (see DOCS/HTML/en/faq.html).

Check "configure.log" if you do not understand why it failed.


后来我上网查 根据faq ,说要把etc/inttypes.h 拷贝到mpalyer目录 我也做了,但是还是出现上面错误 真tmd郁闷

[/b]
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 roylez » 2006-03-25 20:56

试试

代码: 全选

sudo apt-get install libjack0.100.0-0

或者

代码: 全选

sudo apt-get install mplayer
[/code]
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

#3

帖子 shitbaby » 2006-03-25 21:03

joey@ubuntu:~$ sudo apt-get install libjack0.100.0-0
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 libjack0.100.0-0
sorry
shitbaby
帖子: 131
注册时间: 2006-03-22 18:30
送出感谢: 0
接收感谢: 0

#4

帖子 shitbaby » 2006-03-25 21:05

我的是dapper 还在用breezy的源
deb http://ubuntu.cn99.com/ubuntu/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/backports/ breezy-extras main restricted universe multiverse


deb http://mirror.lupaworld.com/ubuntu/archive/ breezy main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy-security main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy-updates main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy-backports main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/ubuntu-cn/ breezy main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/backports/ breezy-extras main restricted universe multiverse

也许是我的源有问题,兄弟你的源给我看看???
头像
tigeric
帖子: 85
注册时间: 2006-04-07 23:31
来自: beijing
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 tigeric » 2006-04-08 15:36

要安装那个版本的呢 ?

代码: 全选

软件包 mplayer 是一个由下面的软件包提供的虚拟软件包:
  mplayer-nogui 1:1.0-pre7cvs20050716-0.1ubuntu9.1
  mplayer-k6 1:1.0-pre7cvs20050716-0.1ubuntu9.1
  mplayer-586 1:1.0-pre7cvs20050716-0.1ubuntu9.1
  mplayer-386 1:1.0-pre7cvs20050716-0.1ubuntu9.1
  mplayer-custom 1:1.0-pre5-0.6ubuntu1


是 k-6 还是 586?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-04-08 17:24

你的系统是什么?/boot下面的vmlinuz这样的文件。或者说你启动grub时,看到的什么版本。
● 鸣学
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2006-04-08 17:49

shitbaby 写了:我的是dapper 还在用breezy的源
也许是我的源有问题,兄弟你的源给我看看???


兄弟,混用源会出问题的……
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2006-04-08 17:52

卧倒。
● 鸣学
xiaozhouzhiyue
帖子: 1
注册时间: 2009-06-14 15:25
送出感谢: 0
接收感谢: 0

Re: dapper无法安装mplayer

#9

帖子 xiaozhouzhiyue » 2009-06-14 15:29

@jianfeng-laptop:~$ sudo apt-get install mplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer: 依赖: libcaca0 (>= 0.99.beta13b-1) 但是它将不会被安装
E: 无法安装的软件包
我的也是这个样子,有两个文件好像不兼容也,装了libcucul0之后libcacal0就不能用,装了libcacal0之后libcucul0就不能用了,这要怎么办呀????各位大侠帮帮我呀
yqw1122
帖子: 35
注册时间: 2009-08-15 22:45
送出感谢: 0
接收感谢: 0

Re: dapper无法安装mplayer

#10

帖子 yqw1122 » 2009-08-27 21:02

我的也是出现这样的问题,怎么回事阿?
怎么没有高手解决阿?
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

Re: dapper无法安装mplayer

#11

帖子 cnkilior » 2009-08-27 21:12

挖坟,该杀!

-----
dapper已死,有事烧纸!
yqw1122
帖子: 35
注册时间: 2009-08-15 22:45
送出感谢: 0
接收感谢: 0

Re: dapper无法安装mplayer

#12

帖子 yqw1122 » 2009-08-27 21:30

我已经解决了这个问题,我主要是通过修改更新源解决的
方法如下:
sudo gedit /etc/apt/sources.list
把打开的文件的内容修改为:
deb http://ubuntu.dormforce.net/ubuntu/ hardy main multiverse restricted universe
deb http://ubuntu.dormforce.net/ubuntu/ hardy-backports main multiverse restricted universe
deb http://ubuntu.dormforce.net/ubuntu/ hardy-proposed main multiverse restricted universe
deb http://ubuntu.dormforce.net/ubuntu/ hardy-security main multiverse restricted universe
deb http://ubuntu.dormforce.net/ubuntu/ hardy-updates main multiverse restricted universe
deb-src http://ubuntu.dormforce.net/ubuntu/ hardy main multiverse restricted universe
deb-src http://ubuntu.dormforce.net/ubuntu/ hardy-backports main multiverse restricted universe
deb-src http://ubuntu.dormforce.net/ubuntu/ hardy-proposed main multiverse restricted universe
deb-src http://ubuntu.dormforce.net/ubuntu/ hardy-security main multiverse restricted universe
deb-src http://ubuntu.dormforce.net/ubuntu/ hardy-updates main multiverse restricted universe
然后保存退出

再打入命令 sudo apt-get update

这样就可以 ,然后打入 sudo apt-get install mplayer
完美解决问题

最后罗唆一下了,很多高手都懒得回答我们菜鸟的问题,真的阻碍了我们从windows转向linux!!!!
回复

回到 “老旧版本支持”