[问题]求助。。。现在在安装软件,其中提到要按照libssl-dev.但是我不知如何。

为当前最终发行版之前的所有版本提供支持
回复
tt7646
帖子: 163
注册时间: 2006-03-26 17:16
来自: 广东中山
送出感谢: 0
接收感谢: 0

[问题]求助。。。现在在安装软件,其中提到要按照libssl-dev.但是我不知如何。

#1

帖子 tt7646 » 2006-03-27 9:10

2.2.?drcomsuite在ubuntu 5.10下的安装
面具体说一下在ubuntu的安装过程,可能要稍微复杂一点,因为ubuntu是开发来用做服务器或者桌面应用的,但是在开发方面可能就要考虑少一点,但是不是说它不合适做开发,有了apt,有了“新立得”什么拿不到呢?并且我们的工作站就是装ubuntu,只不过你在做内核方面的东西时要装些东西上来,让它具有这个环境,ubuntu的设计理念是“Linux for human beings”,所以预装的软件包不会包括编译环境。ubuntu非常的漂亮,没有其他的一些复杂的东西要设置,放上去就能用,所以选它做事情是非常合适的,我很喜欢它!具体的安装我就不说了,在ubuntu中文网站上有详细的教程,http://www.ubuntu.org.cn, ubuntu中文上的资料非常的好而且多, ubuntu很适合新手,我觉得在这个方面比fedora还好(那个yumex真的有够“郁闷”的,运行慢,与“新立得”比差远了,还有源就清华还有个freshrpms的镜像,个人意见)。

首要因素是你要安装 build-essential 如果你没有安装过,请利用下面的命令安装 sudo apt-get install build-essential 当然你可以用“新立得”,我就很喜欢新立得!

你需要做的第二件事就是安装libssl-dev,这个包包括了drcom需要用到的用于认证加密的md5函数,它需要一个md5.h的头文件,而这个文件在libssl-dev中有,另外libssl-dev还包括了其他好多的用于加密的头文件哦
正如上文中提到的。我从昨晚弄到现在都没有搞定。请大家帮忙。没有他我就不能上网了。。。

谢谢!
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#2

帖子 oneleaf » 2006-03-27 9:26

直接使用apt-get install libssl-dev不行吗?
这个包是系统自带的,可以直接通过光盘的源来安装。
tt7646
帖子: 163
注册时间: 2006-03-26 17:16
来自: 广东中山
送出感谢: 0
接收感谢: 0

#3

帖子 tt7646 » 2006-03-27 9:26

我的安装过程是直接输入apt-get install libssl-dev

提示 无法找到软件包 我猜是要到某个文件夹下输入命令。但是我不知道在哪个文件夹里

在新立得里搜索搜。libssl-dev。但是没有
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#4

帖子 oneleaf » 2006-03-27 9:29

:D
附件
Screenshot.png
tt7646
帖子: 163
注册时间: 2006-03-26 17:16
来自: 广东中山
送出感谢: 0
接收感谢: 0

#5

帖子 tt7646 » 2006-03-27 9:35

oneleaf 写了:直接使用apt-get install libssl-dev不行吗?
这个包是系统自带的,可以直接通过光盘的源来安装。


谢谢。

我就是这样安装的。直接进入终端。然后输入命令。apt-get install libssl-dev

光盘也已经放在光驱里面了

提示还是无法找到文件
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#6

帖子 leal » 2006-03-27 9:48

应该是你的/etc/apt/sources.list 设置没把光盘或其它源包含在里头
用心×恒 | 豆瓣 | 门户 | Blog
tt7646
帖子: 163
注册时间: 2006-03-26 17:16
来自: 广东中山
送出感谢: 0
接收感谢: 0

#7

帖子 tt7646 » 2006-03-27 9:53

leal 写了:应该是你的/etc/apt/sources.list 设置没把光盘或其它源包含在里头
请问药如何设置。。/





ps:谢谢管理员。但是我的心理的里面是没有那个的。
刚才在群里面找到人帮忙了。已经把libssl-dev装上了。
头像
callia
帖子: 171
注册时间: 2006-04-10 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 callia » 2006-04-11 17:31

怎么解决的说阿。。。让我这种有同样问题的人看到了希望又绝望。。。。。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2006-04-11 17:33

man apt-cdrom
● 鸣学
头像
crazybug
帖子: 26
注册时间: 2006-03-18 11:09
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 crazybug » 2006-04-12 0:01

为什么我的5.10里面的软件包只有1500左右 上面的贴图中却有10000多?
头像
crazybug
帖子: 26
注册时间: 2006-03-18 11:09
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 crazybug » 2006-04-13 2:46

不知道楼主的 问题解决没有?我和你遇到的是一样的问题 既然提示你缺少什么包 就到网上下载就是了 如果是双系统的话 可以直接在另外的系统下载下来 挂到linux下 使用就可以了 如果不是双系统 就找一个可以上网的机子 下载 使用 U盘考过来。 安装就可以了 其中遇到需要什么依赖 关系的包 就继续下载 直到成功为止。我的已经安装成功了。希望楼主 好运!
Ps:我也是新手,昨天开始接触linux 系统装了两次 遇到的问题多多 希望 大家可以多多指教。 :D
回复

回到 “老旧版本支持”