当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : "Sudo" does not work
帖子发表于 : 2006-03-30 0:20 
头像

注册: 2006-03-29 19:12
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
Hello, I am a new fish in Ubuntu and encountered 2 problems after installation. Can anybody help me to solve them?

1. I created an ordinary account tt in the installation. And then I logged in the Gnome with that account. However I cant use the "Sudo" command in the terminal.

I did see the prompting asking me for the password, but when I input it(should be correct), nothing happened.

For example, I want to enter /usr/share/fonts/zh_CN/TrueType:

cd /usr/share/fonts/zh_CN/TrueType (in /home/tt at the moment)
$%$£"%: (Permission denied)
sudo cd /usr/share/fonts/zh_CN/TrueType
Password: (*********)

and I found i was still in /home/tt !!

other commands with sudo does not work as well.

2. I logged as administrative(root), and edit the /boot/grub/menu.lst in vi. I put some "#"s before (title linux????????), and when I restarted, I can only be directed to Windows XP. the options for Ubuntu have been shaded.

I know I can use "e" to enter the editor mode and I am fully aware of the location of the system (hda2), but how to go on with the command beginning with " kernel"...

Please inform me how can I do to recover the system? (I am using the Ubuntu 5.10 installation CD and choose the default kernel)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-03-30 0:24 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
只有第一个帐号。uid1000的那个可以sudo.


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-03-30 0:28 
头像

注册: 2006-03-29 19:12
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
Thank Eexpress's reply.

But I have only one ordinary account tt and the root account. So ... which one should have UID1000?

I reckon root user doesn't need sudo, huh?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-03-30 5:30 
头像

注册: 2006-03-29 19:12
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
Got it.

Simply add tt (the user's name) to /etc/sudoer


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-03-30 9:48 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
第一个用户应该自动进入sudoer组的。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-03-30 9:52 

注册: 2006-03-16 11:25
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
你可以用安装盘恢复系统试一下

如果不行,试一下把grup装在win下c盘,然后编写menu.list

并且修改 win的 boot.ini


这个你google一下

需要下载一个 grup for dos


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-03-31 2:43 
头像

注册: 2006-03-29 19:12
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
hallywang 写道:
你可以用安装盘恢复系统试一下

如果不行,试一下把grup装在win下c盘,然后编写menu.list

并且修改 win的 boot.ini


这个你google一下

需要下载一个 grup for dos


I have already reinstall it.

Anyway, Thank you for your reply~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译