[问题]怎么样装OPERA浏览器呢

为当前最终发行版之前的所有版本提供支持
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

[问题]怎么样装OPERA浏览器呢

#1

帖子 必敬 » 2006-03-30 13:18

我今天下了个opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb的安装文件,但是不知道怎么装在我的系统里。
看过教程装上了个DOWNLODEA FOR X的程序,说真的,我是照做的里面的关键字眼还是没看懂,
我把这个文件放在桌面了。
请大家帮我怎么样把它装进系统中,谢谢了,
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 内存不足 » 2006-03-30 13:51

cd ~/Desktop
sudo dpkg -i opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

#3

帖子 必敬 » 2006-03-30 14:49

ubuntu@ubuntu:~$ cd ~/Desktop
ubuntu@ubuntu:~/Desktop$ sudo dpkg -i opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb
Password:
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 82084 个文件和目录。)
正在解压缩 opera (从 opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb) ...
dpkg:依赖关系问题使得 opera 的配置工作不能继续:
opera 依赖于 xlib6g (>= 3.3.6) | xlibs;然而:
软件包 xlib6g还没有被安装。
软件包 xlibs还没有被安装。
opera 依赖于 libqt3c102-mt;然而:
软件包 libqt3c102-mt还没有被安装。
dpkg:处理 opera (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
opera
ubuntu@ubuntu:~/Desktop$



要装软件的时候,首先要先进入存放文件的目录中cd ~/Desktop ?然后现用命令sudo dpkg -i 打开安装文件?是不是这样子。


像上面的提示说,是不是我还有些软件没有装上去,如:软件包 xlib6g
软件包 xlibs。 软件包 libqt3c102-mt还没有被安装。要先装上这三个软件再说是吧。

谢谢楼上兄弟。
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 内存不足 » 2006-03-30 15:22

是的 要把依赖的包都装上 我不用opera 这里eexpress是铁杆粉丝

dpkg -i 命令是安装下載到本地的deb包

好像源里有现成的opera 8.5
sudo apt-get install opera ?
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

#5

帖子 必敬 » 2006-03-30 15:23

ubuntu@ubuntu:~$ cd ~/Desktop
ubuntu@ubuntu:~/Desktop$ sudo dpkg -i opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 83355 个文件和目录。)
正在解压缩 opera (从 opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb) ...
dpkg:依赖关系问题使得 opera 的配置工作不能继续:
opera 依赖于 libqt3c102-mt;然而:
软件包 libqt3c102-mt还没有被安装。
dpkg:处理 opera (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
opera
ubuntu@ubuntu:~/Desktop$



各位大大,我真的搞不定这个了,到这里势底了!应该怎么做啊?
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

#6

帖子 必敬 » 2006-03-30 15:29

内存不足 写了:是的 要把依赖的包都装上 我不用opera 这里eexpress是铁杆粉丝

dpkg -i 命令是安装下載到本地的deb包

好像源里有现成的opera 8.5
sudo apt-get install opera ?

ubuntu@ubuntu:~$ sudo apt-get install opera
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
opera 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
opera: 依赖: libqt3c102-mt 但却无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
ubuntu@ubuntu:~$ apt-get -f install
E: 无法打开锁文件 /var/lib/apt/lists/lock - open (13 权限不够)
E: 无法对状态列表目录加锁
ubuntu@ubuntu:~$

libqt3c102-mt 这个到底是做啥用的?
你介绍的那个怎么装?谢谢。

看样子,今天不学点东东都难啊,嘿 嘿
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 内存不足 » 2006-03-30 15:45

sudo apt-get -f install
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2006-03-30 15:48

libqt3-mt试试
● 鸣学
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

#9

帖子 必敬 » 2006-03-30 16:40

内存不足 写了:sudo apt-get -f install
ubuntu@ubuntu:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
下列软件包将被【卸载】:
opera
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 62 个软件未被升 级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 9724kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 83458 个文件和目录。)
正在删除 opera ...
ubuntu@ubuntu:~$

停在这里不动了,
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

#10

帖子 必敬 » 2006-03-30 16:41

eexpress 写了:libqt3-mt试试
是不是要我在新立得软件包里把libqt3-mt装上试试?好像有装过,没用。
必敬
帖子: 26
注册时间: 2005-11-29 11:23
送出感谢: 0
接收感谢: 0

#11

帖子 必敬 » 2006-03-30 17:16

郁闷,我被彻底打败,
ubuntu@ubuntu:~$ cd ~/Desktop
ubuntu@ubuntu:~/Desktop$ sudo dpkg -i opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb
Password:
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 85980 个文件和目录。)
正在解压缩 opera (从 opera_8.52-20060201.5-shared-qt_en_sarge_i386.deb) ...
dpkg:依赖关系问题使得 opera 的配置工作不能继续:
opera 依赖于 libqt3c102-mt;然而:
软件包 libqt3c102-mt还没有被安装。
dpkg:处理 opera (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
opera
ubuntu@ubuntu:~/Desktop$



opera 依赖于 libqt3c102-mt;然而:
软件包 libqt3c102-mt还没有被安装。 这玩意到底是做啥的,!
头像
quincey
帖子: 3
注册时间: 2006-03-30 23:06
送出感谢: 0
接收感谢: 0

#12

帖子 quincey » 2006-03-30 23:23

真是复杂啊!
头像
jaylion
帖子: 67
注册时间: 2005-11-20 4:07
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 jaylion » 2006-03-31 8:42

其实不管什么软件要是源里面有的话,还是用新得力取得这样最好的..
免得又缺这缺那的..就是太受不了了...
每次都搞的我头大死了..好像没有几次有成功装过一个网上下来的deb包..
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#14

帖子 nmvr2600 » 2006-03-31 9:14

请到这里下载opera9的static deb安装包。share你装上了输入法也会出问题。
http://snapshot.opera.com/unix/Weekly-197/intel-linux/
如果你用的5.10的话可以在/etc/apt/sources.list中加入opera源
# The Opera Web Browser
deb http://deb.opera.com/opera/ stable non-free
deb http://deb.opera.com/opera/ testing non-free
deb http://deb.opera.com/opera/ unstable non-free
然后直接使用apt安装

使用下载的包安装提示少包是可以使用 aptitude安装缺失包。
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#15

帖子 eexpress » 2006-03-31 9:22

我在ftp里面放了opera9。0-2的静态包。你直接用哪个。
libqt3c102-mt的我记得源有的。主要是我现在用dapper的源。可能和你的不同,所以没找到。
● 鸣学
回复

回到 “老旧版本支持”