[问题]apt-get中认证的问题

为当前最终发行版之前的所有版本提供支持
回复
jswanli
帖子: 10
注册时间: 2006-03-19 14:34
送出感谢: 0
接收感谢: 0

[问题]apt-get中认证的问题

#1

帖子 jswanli » 2006-04-02 16:02

我使用apt-get install kubuntu-desktop来安装kde桌面,结果出现大量无法通过验证的软件包,请问我应该怎么作?出错如下:
………………………………………………………………………………
软件包 /var/cache/apt/archives/kcron_4%3a3.5.0-0ubuntu0breezy2_i386.deb 没有通 过验证!
正在验证 /var/cache/apt/archives/python2.4-dev_2.4.2-1_i386.deb ...
debsig: Origin Signature check failed. This deb might not be signed.

dpkg:处理 /var/cache/apt/archives/python2.4-dev_2.4.2-1_i386.deb (--unpack)时出错:
软件包 /var/cache/apt/archives/python2.4-dev_2.4.2-1_i386.deb 没有通过验证!
dpkg:出现过多错误,正在终止
在处理时有错误发生:
/var/cache/apt/archives/sanekonsole_0.2-0ubuntu1_i386.deb
/var/cache/apt/archives/libtdb1_1.0.6-13_i386.deb
/var/cache/apt/archives/debtags_1.4+svn20050912-0ubuntu1_i386.deb
/var/cache/apt/archives/adept_1.0_i386.deb
/var/cache/apt/archives/artsbuilder_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/liboggflac3_1.1.2-1ubuntu2_i386.deb
/var/cache/apt/archives/libsamplerate0_0.1.1-2_i386.deb
/var/cache/apt/archives/akode_4%3a3.4.3-0ubuntu1_i386.deb
/var/cache/apt/archives/libgnokii2_0.6.8-0.2_i386.deb
/var/cache/apt/archives/libgpgme11_1.0.2-1build1_i386.deb
/var/cache/apt/archives/libkleopatra1_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/libktnef1_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/kaddressbook_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/libkcal2b_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/libkdepim1a_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/akregator_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/amarok-gstreamer_2%3a1.3.7-0ubuntu4~breezy1_i386.deb
/var/cache/apt/archives/libtag1c2_1.3.1-1.1ubuntu1_i386.deb
/var/cache/apt/archives/libtunepimp2c2_0.3.0-2ubuntu7_i386.deb
/var/cache/apt/archives/amarok_2%3a1.3.7-0ubuntu4~breezy1_i386.deb
/var/cache/apt/archives/ark_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/arts_1.5.0-0ubuntu0breezy1_all.deb
/var/cache/apt/archives/enscript_1.6.4-7_i386.deb
/var/cache/apt/archives/gtk2-engines-gtk-qt_0.60-1ubuntu5_i386.deb
/var/cache/apt/archives/libkipi0_0.1.1-2build2_i386.deb
/var/cache/apt/archives/gwenview_1.2.0-0ubuntu4_i386.deb
/var/cache/apt/archives/imagemagick_6%3a6.2.3.4-1ubuntu1.1_i386.deb
/var/cache/apt/archives/ivman_0.6.3-0ubuntu2_i386.deb
/var/cache/apt/archives/libdbus-qt-1-1c2_0.36.2-0ubuntu7_i386.deb
/var/cache/apt/archives/libflac++5c2_1.1.2-1ubuntu2_i386.deb
/var/cache/apt/archives/k3blibs_0.12.7-1ubuntu1~breezy1_i386.deb
/var/cache/apt/archives/libkonq4_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/libxcomposite1_1%3a0.2.0-3_i386.deb
/var/cache/apt/archives/kdebase-data_4%3a3.5.0-0ubuntu0breezy1_all.deb
/var/cache/apt/archives/kicker_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/kcontrol_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/k3b_0.12.7-1ubuntu1~breezy1_i386.deb
/var/cache/apt/archives/libmodplug0c2_1%3a0.7-4.1_i386.deb
/var/cache/apt/archives/libxine1c2_1.0.1-1ubuntu10.2_i386.deb
/var/cache/apt/archives/kaffeine-gstreamer_0.7.1-1.3ubuntu1~breezy1_i386.deb
/var/cache/apt/archives/kaffeine_0.7.1-1.3ubuntu1~breezy1_i386.deb
/var/cache/apt/archives/kamera_4%3a3.5.0-0ubuntu0breezy1.3_i386.deb
/var/cache/apt/archives/kappfinder_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/karm_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/katapult_0.3.1-0ubuntu2~breezy1_i386.deb
/var/cache/apt/archives/kate_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/libkcddb1_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/kdemultimedia-kio-plugins_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/kaudiocreator_4%3a3.5.0-0ubuntu0breezy1_i386.deb
/var/cache/apt/archives/kcron_4%3a3.5.0-0ubuntu0breezy2_i386.deb
/var/cache/apt/archives/python2.4-dev_2.4.2-1_i386.deb
由于出现了太多错误,处理过程被终止了。
E: Sub-process /usr/bin/dpkg returned an error code (1)
jswanli
帖子: 10
注册时间: 2006-03-19 14:34
送出感谢: 0
接收感谢: 0

#2

帖子 jswanli » 2006-04-02 16:06

以前我也碰到过这种问题,那是我安装kdevelop3的时候,无法通过验证,我只好使用dpkg -i --force bad-verify kdevelop*来安装,可是这次的包实在是太多了。
还有,通过上述命令安装的包,就没办法使用apt-get -f install来删除因为依赖关系而无法运行的包了,是否只能用dpkg -p (或者-r)来卸载?
bbmd
帖子: 12
注册时间: 2006-04-01 23:32
送出感谢: 0
接收感谢: 0

#3

帖子 bbmd » 2006-04-02 20:54

kde在ubuntu中的包叫“kubuntu-desktop”??
我是个ubuntu新手,见笑了
头像
oneleaf
论坛管理员
帖子: 10237
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#4

帖子 oneleaf » 2006-04-02 21:42

apt-get clean
然后删除所有非官方的源。
再次安装 kubuntu-desktop
jswanli
帖子: 10
注册时间: 2006-03-19 14:34
送出感谢: 0
接收感谢: 0

#5

帖子 jswanli » 2006-04-03 9:42

源里面我按照Ubuntu中文官方网站上“快速设置指南”中推荐的写的,如下:
deb http://ubuntu.cn99.com/ubuntu/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/backports/ breezy-extras main restricted universe multiverse
这个不算官方的吗?
jswanli
帖子: 10
注册时间: 2006-03-19 14:34
送出感谢: 0
接收感谢: 0

#6

帖子 jswanli » 2006-04-05 16:40

从网上找到一个解决的方法,根据《Debian 安全手册 第 7 章 - Debian 的安全机制》中提到的“在/etc/dpkg/dpkg.cfg 引入 "no-debsig"”,然后就可以不验证的去直接apt-get了,不过及其危险,所以平时大家还是尽量让它去验证好了。
该文网址为:
http://www.linuxsir.org/bbs/showthread.php?t=173916

我们只需要
sudo gedit /etc/dpkg/dpkg.cfg
然后在最后面加入no-debsig
然后再apt-get,一切OK

回3楼:kubuntu-desktop是ubuntu下的kubuntu桌面,实际上也算是kde了
回复

回到 “老旧版本支持”