IBM R40 ATI Radeon 7500 32M (M7) dapper 6.06如何安装XGL?

为当前最终发行版之前的所有版本提供支持
回复
zxc005
帖子: 6
注册时间: 2006-04-03 5:10
送出感谢: 0
接收感谢: 0

IBM R40 ATI Radeon 7500 32M (M7) dapper 6.06如何安装XGL?

#1

帖子 zxc005 » 2006-04-04 2:53

IBM R40 ATI Radeon 7500 32M (M7) + dapper 6.06 如何安装XGL?

http://www.freedesktop.org/~davidr/xgl-demo1.xvid.avi

自从看了这个demo手就一直痒痒地难受,搜遍了论坛的帖子,还是一头雾水,想下手,又不敢,不好受啊!兄弟们谁有相关经验,帮帮我吧,多谢了!
上次由 zxc005 在 2006-04-04 19:59,总共编辑 1 次。
sotux
帖子: 9
注册时间: 2006-03-22 20:28
送出感谢: 0
接收感谢: 0

#2

帖子 sotux » 2006-04-04 17:18

你用 open source 的驱动试试吧,不要用 ati 的官方驱动,我的 9200 一用官方的就花屏,但 open source 的就可以,只是速度没有 nvidia 的快。
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#3

帖子 catinsnow » 2006-04-04 17:33

参看这里:
https://wiki.ubuntu.com/compiz

BTW:Radeon 7500也用不了官方的驱动.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
zxc005
帖子: 6
注册时间: 2006-04-03 5:10
送出感谢: 0
接收感谢: 0

#4

帖子 zxc005 » 2006-04-04 20:48

sotux 写了:你用 open source 的驱动试试吧,不要用 ati 的官方驱动,我的 9200 一用官方的就花屏,但 open source 的就可以,只是速度没有 nvidia 的快。
请问“open source 的驱动”到哪里去下载,如何安装?再次感谢!
sotux
帖子: 9
注册时间: 2006-03-22 20:28
送出感谢: 0
接收感谢: 0

#5

帖子 sotux » 2006-04-04 22:25

就是 xorg 自带的。
webdone
帖子: 12
注册时间: 2005-12-14 13:59
送出感谢: 0
接收感谢: 0

#6

帖子 webdone » 2006-04-05 23:35

我的是T30,7500 16M,用xorg自带的驱动,安装XGL之后感觉很慢
没有实际的使用意义……
ATI的驱动放弃了M7,至少要M9以上才支持
zxc005
帖子: 6
注册时间: 2006-04-03 5:10
送出感谢: 0
接收感谢: 0

#7

帖子 zxc005 » 2006-04-06 0:28

webdone 写了:我的是T30,7500 16M,用xorg自带的驱动,安装XGL之后感觉很慢
没有实际的使用意义……
ATI的驱动放弃了M7,至少要M9以上才支持
都整到这份儿上了不干不甘心阿!

兄弟,能告诉我你是怎么做的吗?我就是太弱,从没有用过ubunto,多谢了!
rApJtR
帖子: 221
注册时间: 2005-08-01 20:35
来自: Hong Kong
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 rApJtR » 2006-04-06 4:08

我装的结果是 窗口的边框没有了 然后什么特效都没有……

还有就是因为边框没有了 所以窗口也不能移动了
桌面也不能切换了 选定文字会出现类似贴图错误的东西
webdone
帖子: 12
注册时间: 2005-12-14 13:59
送出感谢: 0
接收感谢: 0

#9

帖子 webdone » 2006-04-06 9:23

呵呵,贴图错误这个我也遇到过。至于说窗口边框没有了,没有特效,
这个是因为没有安装compiz或者安装了compiz没有正确运行的原因了
看看这个帖子:
http://www.ubuntuforums.org/showthread.php?t=131253
估计你缺少的就是下面两步:
6. Modify your session ("Menu System" -> "Preferences" -> "Sessions") by adding in the following two items:

代码: 全选

gnome-window-decorator (must be on top, start first) compiz --replace gconf
7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:

代码: 全选

gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher
webdone
帖子: 12
注册时间: 2005-12-14 13:59
送出感谢: 0
接收感谢: 0

#10

帖子 webdone » 2006-04-06 9:27

另外,建议看看这个帖子:
XGL and Compiz eyecandy: One thread to rule them all... (Index)

可能里面的这个:
Xgl/compiz on an Intel i915 video card with DRI
更加合适Ati M7的卡。不用管里面所说的i915驱动怎么安装,
直接从修改x.org文件开始,修改里面的glx,DRI部分。
不过这几个选项一般都已经打开了。打开x.org对比一下看到没有补上应该就可以了
zxc005
帖子: 6
注册时间: 2006-04-03 5:10
送出感谢: 0
接收感谢: 0

#11

帖子 zxc005 » 2006-04-06 16:44

webdone 写了:另外,建议看看这个帖子:
XGL and Compiz eyecandy: One thread to rule them all... (Index)

可能里面的这个:
Xgl/compiz on an Intel i915 video card with DRI
更加合适Ati M7的卡。不用管里面所说的i915驱动怎么安装,
直接从修改x.org文件开始,修改里面的glx,DRI部分。
不过这几个选项一般都已经打开了。打开x.org对比一下看到没有补上应该就可以了
多谢webdone兄弟,我去试试~
rApJtR
帖子: 221
注册时间: 2005-08-01 20:35
来自: Hong Kong
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 rApJtR » 2006-04-09 4:12

The latest compiz package may have a bug that doesn't put the necessary gconf settings in place. One possible work-around is to install the battlehorse v1 deb for compiz, then update to the universe deb.
我果然找不到那些设置选项的……
回复

回到 “老旧版本支持”