firefox出错 (已解决)

为当前最终发行版之前的所有版本提供支持
回复
cashlu
帖子: 142
注册时间: 2005-10-03 3:30
送出感谢: 0
接收感谢: 0
联系:

firefox出错 (已解决)

#1

帖子 cashlu » 2006-04-04 22:43

今天我的Firefox1.5突然不能用了,错误提示如下:

cashlu@ubuntu:~/software/firefox$ ./firefox
./run-mozilla.sh: line 131: 9687 段错误 "$prog" ${1+"$@"}

cashlu@ubuntu:~/software/firefox$ ./firefox-bin
段错误

之前还好好的,请教各位只是怎么回事?Thunderbird也一样:

cashlu@ubuntu:~/software/thunderbird$ ./thunderbird
./run-mozilla.sh: line 131: 9797 段错误 "$prog" ${1+"$@"}

cashlu@ubuntu:~/software/thunderbird$ ./thunderbird-bin
./thunderbird-bin: error while loading shared libraries: libldap50.so: cannot open shared object file: No such file or directory
上次由 cashlu 在 2006-04-06 0:52,总共编辑 1 次。
cashlu
帖子: 142
注册时间: 2005-10-03 3:30
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 cashlu » 2006-04-06 0:52

这个解决了!Google查了一下,原来是因为SCIM与Firefox 1.5等软件冲突的缘故。
解决方法也很简单,以Firefox为例,编辑firefox.sh,加入如下语句:

代码: 全选

export GTK_IM_MODULE=xim


建议也把这个问题写入新手指南中!
头像
choukuangjay
帖子: 274
注册时间: 2006-01-17 14:39
来自: Nanking
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 choukuangjay » 2006-04-22 18:56

cashlu 写了:这个解决了!Google查了一下,原来是因为SCIM与Firefox 1.5等软件冲突的缘故。
解决方法也很简单,以Firefox为例,编辑firefox.sh,加入如下语句:

代码: 全选

export GTK_IM_MODULE=xim


建议也把这个问题写入新手指南中!


太感谢了,终于搞定了。我还绕了一个大弯去自己编译firefox来解决这个问题呢,结果花了3小时却告诉我出错。
ID:死乘把口, Matrix Chou
寨本网 山寨笔记本大本营
cashlu
帖子: 142
注册时间: 2005-10-03 3:30
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 cashlu » 2006-04-22 21:07

choukuangjay 写了:
cashlu 写了:这个解决了!Google查了一下,原来是因为SCIM与Firefox 1.5等软件冲突的缘故。
解决方法也很简单,以Firefox为例,编辑firefox.sh,加入如下语句:

代码: 全选

export GTK_IM_MODULE=xim


建议也把这个问题写入新手指南中!


太感谢了,终于搞定了。我还绕了一个大弯去自己编译firefox来解决这个问题呢,结果花了3小时却告诉我出错。



呵呵~~~~~这个问题我也郁闷了很久,解决就好
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#5

帖子 renex » 2006-05-01 12:48

严重好贴,顶上去
回复

回到 “老旧版本支持”