求助!!!

为当前最终发行版之前的所有版本提供支持
回复
JColder
帖子: 1
注册时间: 2006-03-24 11:51
送出感谢: 0
接收感谢: 0

求助!!!

#1

帖子 JColder » 2006-04-05 11:51

我是 最近才开始学用ubuntu的,觉得挺棒的,但是是菜鸟阿 ,很多东西都不懂。
我在sudo apt-get dist-upgrade的时候,出现依赖关系的 问题,如下:

代码: 全选

下列的软件包有不能满足的依赖关系:
  libdmx1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libfontenc1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libfs6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libice6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libsm6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libx11-6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
            预依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxau6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxaw7: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxdamage1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxdmcp6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxext6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxfixes3: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxfont1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxi6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxinerama1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxkbfile1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxmu6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxmuu1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxp6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxpm4: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxrandr2: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxres1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxss1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxt6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxtrap6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxtst6: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxv1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxxf86dga1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxxf86misc1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  libxxf86vm1: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  xfonts-100dpi: 预依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  xfonts-75dpi: 预依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  xfonts-base: 预依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  xfonts-scalable: 预依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  xlibs: 依赖: xlibs-data 但是它还没有被安装
  xserver-xorg: 依赖: x11-common 但却无法安装它
                预依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
  xserver-xorg-core: 依赖: x11-common 但却无法安装它
  xterm: 依赖: x11-common (>= 7.0.0-0ubuntu3) 但却无法安装它
E: 不能满足依赖关系。不妨试一下 -f 选项。

原来是没有这些问题的,是 在 安装多媒体的时候出现依赖问题,然后我按照网上的一些方法,就是用dpkg -P --force-depends x11-common xorg-common 之后,就 出现上面的问题,
求救阿 !!!!现在装什么 都说 这个 依赖问题,晕~~~~~~~~
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-04-05 12:39

update, 安装x11-common, 再upgrade. 试试
● 鸣学
回复

回到 “老旧版本支持”