求救:安装新内核后启动失败

为当前最终发行版之前的所有版本提供支持
回复
dayongxie
帖子: 10
注册时间: 2006-03-21 22:56
送出感谢: 0
接收感谢: 0

求救:安装新内核后启动失败

#1

帖子 dayongxie » 2006-04-06 12:47

原来的安装的内核是linux-image-2.6.12-10-386
通过apt安装了一个linux-image-2.6.15-19-k7
然后就不能启动了。
从grub菜单选择启动2.6.15时到加载根文件系统时就挂了:
Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Done.
Begin: Waiting for root file system... ...
到这里就停止了。

选择2.6.12也启动到这里,出现了段错误:

...
[4294669.473000] PCI:Cannt allocate resource region 4 of device 0000:00:07.1
...
Begin: Waiting for root file system... ...
Segmentation fault
Segmentation fault
...
一长串"Segmentation fault"
..
Done
ALERT! /dev/hda15 does not exist. Dropping to a shell!


我实在没招了,请高手救救我的ubuntu吧。
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#2

帖子 leal » 2006-04-06 15:15

你用的是k7 CPU?
用心×恒 | 豆瓣 | 门户 | Blog
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#3

帖子 nmvr2600 » 2006-04-06 16:06

用这个linux-image-2.6.12-10-386的救援模式能否启动?
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
dayongxie
帖子: 10
注册时间: 2006-03-21 22:56
送出感谢: 0
接收感谢: 0

#4

帖子 dayongxie » 2006-04-06 16:17

cpu是AMD 闪龙2200+,主板是华擎k7S41

安装内核2.6.15时,也把安装ubuntu时默认的内核给删了。
dayongxie
帖子: 10
注册时间: 2006-03-21 22:56
送出感谢: 0
接收感谢: 0

#5

帖子 dayongxie » 2006-04-06 16:33

也启动不了。
结果是一样的。
纳闷,两个内核不可能同时出问题吧。
希望不需要重装系统。
dayongxie
帖子: 10
注册时间: 2006-03-21 22:56
送出感谢: 0
接收感谢: 0

#6

帖子 dayongxie » 2006-04-07 19:28

决定重装系统
头像
szlychee
帖子: 60
注册时间: 2006-03-15 22:34
送出感谢: 0
接收感谢: 0

#7

帖子 szlychee » 2006-04-10 18:02

遇到同样的问题,是bug吧?
回复

回到 “老旧版本支持”