按照安装指南上更新解码器出错了!

为当前最终发行版之前的所有版本提供支持
回复
fralium
帖子: 13
注册时间: 2006-04-06 17:05
送出感谢: 0
接收感谢: 0
联系:

按照安装指南上更新解码器出错了!

#1

帖子 fralium » 2006-04-06 19:19

按照这个提示安装的更新,http://www.ubuntu.org.cn/support/documentation/guide/codecs
然后提示出错,

--------------------------
dextor@dextor:~$ sudo apt-get install gstreamer0.8-plugins
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
gstreamer0.8-plugins 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

--------------------------

然后我载 dextor@dextor:~$ sudo apt-get install gstreamer0.8-visuals

-------------------------
结果是:

dextor@dextor:~$ sudo apt-get install gstreamer0.8-visuals
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列【新】软件包将被安装:
gstreamer0.8-visuals
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 108 个软件未被升级。
有 34 个软件包没有被完全安装或卸载。
需要下载 0B/63.0kB 的软件包。
解压缩后会消耗掉 176kB 的额外空间。
【警告】:下列的软件包不能通过认证!
gstreamer0.8-visuals
不经验证就安装这些软件包么?[y/N] y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 59294 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

---------------------

现在我该怎么办?大家遇见当初是怎么更新的阿?
fralium
帖子: 13
注册时间: 2006-04-06 17:05
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 fralium » 2006-04-06 19:40

自己顶一下,

刚才从新立得安装更行,貌似又安装上了。

看来我还是比较菜,继续学习!

不过还是希望管理员把那个指南修改一下,不然象我这样的貌似。。。

呵呵!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2006-04-06 19:48

安装软件之前,最好是先apt-get update ,apt-get dist-upgrade一下,更新系统,解决一些依赖问题。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”