请教高手帮忙 编译问题 校园网Dr.com 没有它上不了网啊

为当前最终发行版之前的所有版本提供支持
回复
cloudice
帖子: 19
注册时间: 2006-04-06 22:04
送出感谢: 0
接收感谢: 0

请教高手帮忙 编译问题 校园网Dr.com 没有它上不了网啊

#1

帖子 cloudice » 2006-04-06 23:15

cloudice@ice:~/drcomsuite$ make
make -C include
make[1]: Entering directory `/home/cloudice/drcomsuite/include'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/cloudice/drcomsuite/include'
make -C drcomc
make[1]: Entering directory `/home/cloudice/drcomsuite/drcomc'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/cloudice/drcomsuite/drcomc'
make -C drcomcd
make[1]: Entering directory `/home/cloudice/drcomsuite/drcomcd'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/cloudice/drcomsuite/drcomcd'
make -C module
make[1]: Entering directory `/home/cloudice/drcomsuite/module'
make -C Linux
make[2]: Entering directory `/home/cloudice/drcomsuite/module/Linux'
make -C 2.6.x
make[3]: Entering directory `/home/cloudice/drcomsuite/module/Linux/2.6.x'
make -C /lib/modules/2.6.12-9-386/build M=/home/cloudice/drcomsuite/module/Linux/2.6.x modules
make: *** /lib/modules/2.6.12-9-386/build: 没有那个文件或目录。 停止。
make: Entering an unknown directorymake: Leaving an unknown directorymake[3]: *** [all] 错误 2
make[3]: Leaving directory `/home/cloudice/drcomsuite/module/Linux/2.6.x'
make[2]: *** [all] 错误 2
make[2]: Leaving directory `/home/cloudice/drcomsuite/module/Linux'
make[1]: *** [all] 错误 2
make[1]: Leaving directory `/home/cloudice/drcomsuite/module'
make: *** [module] 错误 2


这是第二个包drcomsuite的编译过程,第一个libdrcom已经编译好了,两个包在附件里,请高手帮忙看看这样的错误一般是什么原因引起的。。
如果哪位好心人能帮忙编译一下,就万分感谢了。。。
附件
DrCOM.zip
(113.78 KiB) 下载 105 次
jiedan
帖子: 10
注册时间: 2006-04-04 18:50
送出感谢: 0
接收感谢: 0

#2

帖子 jiedan » 2006-04-07 10:02

我们学校也是搞的这个,我一直没上了网,能不能给我一个下载地址呀!?
或提供一下:drcomsuite-0.1.12.tar.bz2和libdrcom-0.0-20050423-2.tar.bz2
谢谢先,如果可以发到我的邮箱:lxb429@163.com
cloudice
帖子: 19
注册时间: 2006-04-06 22:04
送出感谢: 0
接收感谢: 0

#3

帖子 cloudice » 2006-04-07 18:47

我发了附件的啊,上面可以下载嘛。你看不到么?
头像
callia
帖子: 171
注册时间: 2006-04-10 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 callia » 2006-04-10 19:30

哈哈哈哈,这个正是我需要的,谢谢了
weyllor
帖子: 8
注册时间: 2006-04-12 10:06
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 weyllor » 2006-04-12 11:59

我在.10 版内核下没编译通过,但在.9内核下成功编译并正在使用.楼主是以下切换到.9内核编译
其他详见Ubuntu.org.cn
打铁的
帖子: 5
注册时间: 2006-04-13 8:10
送出感谢: 0
接收感谢: 0

#6

帖子 打铁的 » 2006-04-13 8:13

可以请教下具体怎么安装的吗?资料很多,但是好像很不具体。还要安装。。。libssl-dev,gcc-3.4什么的。
build-essential
sudo apt-get install build-essential
libssl-dev
Linux-header-file-{yourversion}
安装gcc3.4
至此你就建立了一个可以编译drcomsuite的环境了


开启一个root shell,那么就运行sudo -s -H


编译anzhuang配置{

tar -xjvf libdrcom*.bz2

tar -xjvf drcomsuite*.bz2
打铁的
帖子: 5
注册时间: 2006-04-13 8:10
送出感谢: 0
接收感谢: 0

#7

帖子 打铁的 » 2006-04-13 8:15

有高手指教的,请教。我的油箱wxwwaitna86@188.com
qq:383872947 校园网下一直没上网,内心很是不妥。但是还没放弃。谢谢各位!
gosnowlee
帖子: 81
注册时间: 2006-02-28 17:08
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 gosnowlee » 2006-04-27 18:59

头像
xtayfool
帖子: 218
注册时间: 2005-09-17 10:16
送出感谢: 0
接收感谢: 0

#9

帖子 xtayfool » 2006-05-04 15:50

楼主的问题大概是没安装Linux-header-{yourversion}
参见楼上给的地址
jimmyjia
帖子: 18
注册时间: 2006-04-22 17:02
送出感谢: 0
接收感谢: 0

#10

帖子 jimmyjia » 2006-05-05 10:51

xtayfool 写了:楼主的问题大概是没安装Linux-header-{yourversion}
参见楼上给的地址
恩,楼主应该就是没有安装 linux-header-2.6.12-9-386
另外最近好象drcom官方发布了linux下的客户端,我在我们学校的网络中心主页上看到过,不过是rpm包的
tt7646
帖子: 163
注册时间: 2006-03-26 17:16
来自: 广东中山
送出感谢: 0
接收感谢: 0

#11

帖子 tt7646 » 2006-05-05 14:11

viewtopic.php?p=66378&highlight=#66378


楼主看这里一定可以成功的,好运阿。
回复

回到 “老旧版本支持”