用apt-get install时总是出现lilypond的错误,请哪位帮忙看一下怎么回事.

为当前最终发行版之前的所有版本提供支持
回复
zun
帖子: 27
注册时间: 2005-08-31 23:33
送出感谢: 0
接收感谢: 0

用apt-get install时总是出现lilypond的错误,请哪位帮忙看一下怎么回事.

#1

帖子 zun » 2006-04-07 18:01

最近用apt-get install时总是出现下面那个lilypond的错误,我用apt-get clean 重新下载也没用,请哪位帮忙看一下怎么回事,怎样处理,谢了。

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 87693 个文件和目录。)
正预备替换 lilypond-data 2.6.3-9~breezy1 (使用 .../lilypond-data_2.6.3-9~breezy1_all.deb) ...
正在解压缩将用于更替的包文件 lilypond-data ...
/var/lib/dpkg/info/lilypond-data.postrm: line 23: /usr/bin/kpsewhich: 没有那个文件或目录
dpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 1
dpkg - 现转而试用新软件包所带的脚本...
/var/lib/dpkg/tmp.ci/postrm: line 23: /usr/bin/kpsewhich: 没有那个文件或目录
dpkg:处理 /var/cache/apt/archives/lilypond-data_2.6.3-9~breezy1_all.deb (--unpack)时出错:
子进程·新的 post-removal 脚本·返回了错误号·1
/var/lib/dpkg/tmp.ci/postrm: line 23: /usr/bin/kpsewhich: 没有那个文件或目录
dpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·1
在处理时有错误发生:
/var/cache/apt/archives/lilypond-data_2.6.3-9~breezy1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
若能一切随它去,便是世间自由人。
xgr
帖子: 27
注册时间: 2006-04-06 22:12
送出感谢: 0
接收感谢: 0

#2

帖子 xgr » 2006-04-07 19:13

apt fixbroken看一下
或者apt-get check一下
大概是什么地方升级出错了
回复

回到 “老旧版本支持”