刚升级到dapper的问题(已解决)

为当前最终发行版之前的所有版本提供支持
回复
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

刚升级到dapper的问题(已解决)

#1

帖子 duoxing » 2006-04-09 22:38

今天用了很长的时间终于大部分问题没有了,但是最后几个包升级总是有问题,大家帮忙看看:
duoxing@smartfish:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages have been kept back:
gdk-imlib1 gnome-cups-manager hplip-data libopenal0 openoffice.org-writer
python-netcdf
The following packages will be upgraded:
gstreamer0.8-misc
1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
Need to get 0B/1253kB of archives.
After unpacking 147kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 124986 files and directories currently installed.)
Preparing to replace gstreamer0.8-misc 0.8.11-0unofficialubuntu3 (using .../gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb) ...
Unpacking replacement gstreamer0.8-misc ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb (--unpack):
trying to overwrite `/usr/lib/gstreamer-0.8/libgstgoom.so', which is also in package gstreamer0.8-visuals
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
duoxing@smartfish:~$
用sudo apt-get -f install 也没有任何的反应,大家帮帮忙。
上次由 duoxing 在 2006-04-10 11:26,总共编辑 1 次。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-04-10 8:23

你是升级的啊,升级的话gstreamer0.8-misc这几个包就是会出问题,原因是gnome2.14现在采用的是gstreamer0.10.而老的包由于依赖问题,就会出现你上面的情况.
为了减少麻烦,我觉得最好是全新安装.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 duoxing » 2006-04-10 10:04

那怎么样才能解决这个依赖关系呢?全部都自己下包然后安装可以不呢?
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 duoxing » 2006-04-10 11:25

解决了,只是解决这些依赖关系也不是那么的麻烦。
头像
jazzi
帖子: 532
注册时间: 2005-10-16 23:26
来自: 泉州
送出感谢: 0
接收感谢: 3 次
联系:

#5

帖子 jazzi » 2006-04-10 13:14

duoxing 写了:解决了,只是解决这些依赖关系也不是那么的麻烦。
有什么不麻烦的解决办法,期待分享
You make it fun
It will make you fun
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 duoxing » 2006-04-10 13:17

手动删除 gstreamer0.8的所有东西,然后手动安装 gstreamer0.10的相关东西,这样就可以了。这样就可以避免依赖的关系,就不会出问题,也很方便。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2006-04-10 13:34

我当时升级的时候就是看见有问题就删,但是后来进入系统之后就怕出问题,导致不稳定因素,所以还是重新安装了.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”