opera 9.0 scim输入法问题

为当前最终发行版之前的所有版本提供支持
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

opera 9.0 scim输入法问题

#1

帖子 joe45 » 2006-04-10 2:04

在opera 9.0中输入,为什么光标会跑到最前面??? 比如:打好一句,光标跑到最前面. 非常麻烦阿!!

跑到<-会<-为什么光标 例子: 打完为什么光标,光标跑到前面去了,打会就在前面了....

大家有没有这个问题???
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

#2

帖子 joe45 » 2006-04-10 2:52

opera-static_9.0-20060329.1-qt_en_i386.deb 版本的
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

#3

帖子 joe45 » 2006-04-10 3:12

大家没有遇到这种情况么,好郁闷阿。打一个句子,就要自己移动一下光标到句子的结尾啊!!!
头像
guoshuang
帖子: 153
注册时间: 2006-03-29 11:54
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 guoshuang » 2006-04-13 10:12

我也遇到了
据 eepress 说可能是因为 internationnal fonts 设置为 arabic(阿拉伯) 的缘故。这才发现这个 opera 9 版本这个设置保持不住(设置完了在打开又是 arabic)。
找了半天也找不到 opera 在哪个 ini 文件记录这个信息。谁知道?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-04-13 10:31

我也是这样的.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#6

帖子 nmvr2600 » 2006-04-13 12:45

尝试一下近期的opera,我的是没有问题的。所谓internationnal fonts,是指遇到那种语言会使用你设定的字体去显示而已。
哦,可以尝试把那个什么im_model,记不太清楚了,export输出看一下,scim改成xim可能解决问题。
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2006-04-13 15:57

难道英文输入也这样?
如果想改xim。是这里。
Huahua /etc/X11/xinit/xinput.d/scim-pinyin
GTK_IM_MODULE=scim
● 鸣学
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#8

帖子 nmvr2600 » 2006-04-13 16:30

是的,不过我是在自己home目录中改的,建一个.xinput.d文件夹,里面放一个default文件
内容如下:
XIM=SCIM
XIM_PROGRAM=/usr/bin/scim
XIM_ARGS="-d"
GTK_IM_MODULE=xim
QT_IM_MODULE=scim
DEPENDS="scim,scim-gtk2-immodule | scim-qtimm"

解决输入问题. 我不记得是不是还改过别的地方了, 不过现在即使在opera里scim也输入正常.
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2006-04-13 16:44

我记得/etc/X11/xinit/xinput.d/下面的3个配置文件,已经包含了楼上的设置了。而且好像是源升级时强制设置的。所以不需要修改其他的。
我的opera从来没出过输入的问题。 :lol: 每次大家有问题,我都是猜的。
● 鸣学
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#10

帖子 nmvr2600 » 2006-04-13 17:20

有是有的,不过你可以去看一下/etc/X11/Xsession.d/90im-switch文件,ubuntu是利用它设定输入法的。里面前部分内容如下 :

代码: 全选

lang_region=$(echo $tmplang | sed -e 's/\..*//')
for f in $HOME/.xinput.d/${lang_region} \
	    $HOME/.xinput.d/default \
	    /etc/X11/xinit/xinput.d/${lang_region} \
	    /etc/X11/xinit/xinput.d/default ; do
    [ -r $f ] && . $f && break
done
unset lang_region
系统先去判断你的系统语言,然后再到文件中获取配置的常量。for那一段说明了读取的顺序。先到home里找,然后采取读系统的,到/etc/X11/xinit/xinput.d文件夹中去找,还是系统语言一致的优先,我这里默认是没有default文件的。如果系统为中文那么没有问题,会获取/etc/X11/xinit/xinput.d/zh_CN,如果是英文的呢?默认会没有,所以scim不会启动。我只所以在自己home下建了那么default一个文件就是想不管我系统语言怎么改都让我的输入法和在中文环境中一样启动,因为我的default文件的内容和/etc/X11/xinit/xinput.d/zh_CN是一样的。当然这里的选择有很多,可以在/etc/X11/xinit/xinput.d/这个文件夹中建这么一个default文件。另外系统默认的GTK_IM_MODULE=scim,这个会引起firefox的段错误(指自己从moziila下载安装的),所以我开始使用scim的xim模式,即GTK_IM_MODULE=xim。另外如果还有问题的话可以修改home下.scim/global文件,

代码: 全选

/SupportedUnicodeLocales = en_US.UTF-8,en_GB.UTF_8,zh_CN.UTF-8
把自己用的utf编码加进去。

不过dapper现在scim的启动还是和gdm或kdm有联系,当我把gdm服务关掉使用startx启动X的时候scim虽然同样启动但是并不能输入。具体原因因为最近比较忙也没有去深究。

以前我也曾按照指南里去改过/etc/environment文件,不过总共觉工作的不好,感觉不怎么优雅。让locale变得有些不一致。当然我的方法可能不是最好的方法,也决不是唯一的方法,只是一种思路。如果大家有更好的解决方法我是很愿意知道的。关于输入法的启动如果有人知道的比较详细可以跟大家解释一下。dapper现在的做法比较好理解。
附件
Screenshot.png
效果
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2006-04-13 19:42

楼上的不错哦。可以写点论文了。 :lol: 怎么用小老鼠的?难道只有本本。
● 鸣学
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

#12

帖子 joe45 » 2006-04-13 21:39

改了,还是不行阿!打字好郁闷! 请问怎样删除scim?然后重装试试
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#13

帖子 nmvr2600 » 2006-04-14 8:48

有台式机的,不过都是xfce,本本默认是不启动X的,配置低太慢了,呵呵,所以少用gnome,这也是没有办法的事情。最近还都把主题换成了simple。
啥时有了好机器我也奢侈一下,盼望中。。。。
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
头像
guoshuang
帖子: 153
注册时间: 2006-03-29 11:54
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 guoshuang » 2006-04-14 11:31

http://snapshot.opera.com/unix/Weekly-2 ... r_i386.deb

以前的 opera 版本没有此问题,就是这几天的 weekly 有此问题 。英文也没问题。firefox 也没问题,问题应该出在 这个 opera 版本本身。
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

#15

帖子 joe45 » 2006-04-14 11:55

换了小企鹅输入法,就没有问题了, 之友eva还是不能打 输入中文
只是以前装的eva都没有问题, 这个我是直接用新得利安装的eva,装好之后是英文界面,不过蛮喜欢的, 就是不嫩够输入中文.
自己另外安装中文版的了, 输入还是有问题, 之前的scim也是不嫩够输入, 有知道的高手么?
回复

回到 “老旧版本支持”