[问题]我装了ATI X300的驱动,但是没有3D加速。

为当前最终发行版之前的所有版本提供支持
回复
njchenyi
帖子: 39
注册时间: 2006-03-13 0:19
送出感谢: 0
接收感谢: 0
联系:

[问题]我装了ATI X300的驱动,但是没有3D加速。

#1

帖子 njchenyi » 2006-04-12 22:10

我的opengl报告如下:

# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

想知道该如何解决
cashlu
帖子: 142
注册时间: 2005-10-03 3:30
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 cashlu » 2006-04-13 0:27

安装完成之后,要更改一下xorg.conf文档,把里面的"ati"改成"flgrx"。这个你做了吗?

更改之前记得现备份一下
njchenyi
帖子: 39
注册时间: 2006-03-13 0:19
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 njchenyi » 2006-04-15 16:38

我要是那么修改就没法启动Xwindows,好象是我的fglrx编译的时候错误
cashlu
帖子: 142
注册时间: 2005-10-03 3:30
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 cashlu » 2006-04-15 17:12

你的驱动是自己编译的?

还是不要自己编译了,去ATI的网站下一个最新的驱动,直接安装就可以了

或者直接apt-get,呵呵
kevin_long
帖子: 7
注册时间: 2006-01-02 21:09
送出感谢: 0
接收感谢: 0

#5

帖子 kevin_long » 2006-04-24 18:12

I install the fglrx driver for my X200.
3D enabled.
linux-restrict-modules package must be removed from system.

I check my system, found that restrict package will install a violate folder in your modules/2.x.x./ fglrx.ko will be included in it, it is the pre-compiled driver, can't support 3D, system always load this file for your display card.

if you remove the linux-restrict-modules related packages ( no one package, but several related),

and run depmod to re-calculate the dependency for modules.

system will find the fglrx.ko from /lib/modules/2.x.x/drivers/char/drm/ that is the fglrx installer maked driver file.

I can play F-117 with this driver. FPS is about 35 @ 640x480.
Jeremy
帖子: 224
注册时间: 2005-11-08 10:12
送出感谢: 0
接收感谢: 0

#6

帖子 Jeremy » 2006-04-26 17:56

我在硬件区里贴了文章的,你去看看,可以试下。
回复

回到 “老旧版本支持”