我疯了,怎么什么软件都缺少这个gcc都装不了

为当前最终发行版之前的所有版本提供支持
回复
turn
帖子: 3
注册时间: 2006-03-13 16:05
送出感谢: 0
接收感谢: 0

我疯了,怎么什么软件都缺少这个gcc都装不了

#1

帖子 turn » 2006-04-12 22:46

应该是很弱的问题。。。。。

比如硬盘装deb包
turn@ubuntu:~$ sudo dpkg -i ./turn1/opera-static_9.0-2_all.deb
(正在读取数据库 ... 系统当前总共安装有 58123 个文件和目录。)
正预备替换 opera-static 9.0-2 (使用 .../opera-static_9.0-2_all.deb) ...
正在解压缩将用于更替的包文件 opera-static ...
dpkg:依赖关系问题使得 opera-static 的配置工作不能继续:
opera-static 依赖于 libgcc1 (>= 1:4.0.2);然而:
系统里的 libgcc1 的版本是 1:4.0.1-4ubuntu9.
dpkg:处理 opera-static (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
opera-static

网络apt-get
turn@ubuntu:~$ sudo apt-get install gftp
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gftp: 依赖: gftp-gtk (= 2.0.18-10) 但是它将不会被安装
依赖: gftp-text (= 2.0.18-10) 但是它将不会被安装
opera-static: 依赖: libgcc1 (>= 1:4.0.2) 但是 1:4.0.1-4ubuntu9 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
turn
帖子: 3
注册时间: 2006-03-13 16:05
送出感谢: 0
接收感谢: 0

#2

帖子 turn » 2006-04-12 23:41

不是说apt就没有rpm依赖关系的麻烦了吗,怎么这个还是存在呢
头像
jaylion
帖子: 67
注册时间: 2005-11-20 4:07
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jaylion » 2006-04-13 9:33

linux的安装包依赖关系有时候真的会让人疯掉..
最好的解决方式还是老老实实的安装源里面的包吧..需要什么它自动给你叉上..
头像
firingstone
帖子: 336
注册时间: 2005-07-11 17:37
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 firingstone » 2006-04-13 12:20

是不是你的sources.list 设置有问题,opera可能会有问题,但是源上的gftp不应该有问题啊,你可以看看新手指南再设置一下你的sources.list
ubuntu 5.10 +windowsxpsp2
HP NX6120
PM1.6+512M DDR333+915GM+40G HD+Combo

Life is Struggle!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-04-13 16:02

dpkg的当然有依赖关系。最好是下static版本的deb。就什么都包括了。
apt-get是自动依赖。应该说是你的库没有更新或者有破损的依赖存在,导致这样的结果。新利得里面多刷新一下。
● 鸣学
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2006-04-13 17:30

先 apt-get update,apt-get dist-upgrade一下试试看行不行.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#7

帖子 nmvr2600 » 2006-04-13 18:05

eexpressz兄还是把ftp上那个opera的包换掉好,你做那个包的时候opera9还是处在技术预览阶段,这个星期的才开始beta,正式版不用等太久了。原来bug不说,widgets开发是近期完成的,想用opera9的应该到opera网站上去下载,何况现在opera desktopteam已经开始提供dapper的deb包了呢。现在最新的是build239。用opera的兄弟自己查看下了。没有的可以去下载,http://snapshot.opera.com/unix/Weekly-2 ... r_i386.deb
还有一点要说的是,opera和别的自由软件不一样,虽然现在也不要钱了但是它并不是开源的,这就是为什么在新立得里为什么是non-free里。当然你还是为了大家方便,呵呵,值得表扬,不过不值得鼓励哦。
希望eexpressz兄不要生气。
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2006-04-13 19:36

nmvr2600 写了:eexpressz兄还是把ftp上那个opera的包换掉好,你做那个包的时候opera9还是处在技术预览阶段,这个星期的才开始beta,正式版不用等太久了。原来bug不说,widgets开发是近期完成的,想用opera9的应该到opera网站上去下载,何况现在opera desktopteam已经开始提供dapper的deb包了呢。现在最新的是build239。用opera的兄弟自己查看下了。没有的可以去下载,http://snapshot.opera.com/unix/Weekly-2 ... r_i386.deb
还有一点要说的是,opera和别的自由软件不一样,虽然现在也不要钱了但是它并不是开源的,这就是为什么在新立得里为什么是non-free里。当然你还是为了大家方便,呵呵,值得表扬,不过不值得鼓励哦。
希望eexpressz兄不要生气。
哦。这个包,我用一直正常。主要是想有人要,又不会编译或者解决依赖,所以放那里的。新的出来了,我去看看。放ftp也是临时的。 :lol:
● 鸣学
回复

回到 “老旧版本支持”