[问题]luma出问题了 !!!

为当前最终发行版之前的所有版本提供支持
回复
我是菜鸟我怕谁
帖子: 31
注册时间: 2006-03-17 14:08
送出感谢: 0
接收感谢: 0
联系:

[问题]luma出问题了 !!!

#1

帖子 我是菜鸟我怕谁 » 2006-04-14 8:49

我按照指南上的操作装了Lumaqq,但是不能运行啊,错误提示:
hobby@hobby:/opt/LumaQQ$ Exception in thread "main" java.lang.NoClassDefFoundErr or: while resolving class: edu.tsinghua.lumaqq.LumaQQ
at ._ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE (/usr/lib/l ibgcj.so.6.0.0)
at ._ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang5ErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang12LinkageErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang20NoClassDefFoundErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6 .0.0)
at ._ZN4java4lang13VMClassLoader18transformExceptionEPNS0_5ClassEPNS0_9Throwa bleE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang13VMClassLoader12resolveClassEPNS0_5ClassE (/usr/lib/libgcj. so.6.0.0)
at ._ZN4java4lang5Class15initializeClassEv (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang5Class7forNameEPNS0_6StringEbPNS0_11ClassLoaderE (/usr/lib/l ibgcj.so.6.0.0)
at ._ZN3gnu4java4lang10MainThread3runEv (/usr/lib/libgcj.so.6.0.0)
at ._Z13_Jv_ThreadRunPN4java4lang6ThreadE (/usr/lib/libgcj.so.6.0.0)
at ._Z11_Jv_RunMainP14_Jv_VMInitArgsPN4java4lang5ClassEPKciPS6_b (/usr/lib/li bgcj.so.6.0.0)
at .main (/usr/lib/libgij.so.6.0.0)
at .__libc_start_main (/lib/tls/i686/cmov/libc-2.3.5.so)
Caused by: java.lang.ClassNotFoundException: java.lang.StringBuilder not found i n gnu.gcj.runtime.SystemClassLoader{urls=[file:/opt/LumaQQ/lib/xerces.jar,file:. /,file:/opt/LumaQQ/lib/swt.jar,file:/opt/LumaQQ/lib/poifs.jar,file:./,file:/opt/ LumaQQ/lib/org.eclipse.ui.workbench_3.1.0.jar,file:/opt/LumaQQ/lib/org.eclipse.o sgi_3.1.0.jar,file:./,file:/opt/LumaQQ/lib/org.eclipse.jface_3.1.0.jar,file:/opt /LumaQQ/lib/org.eclipse.emf.ecore.xmi_2.1.0.jar,file:./,file:/opt/LumaQQ/lib/org .eclipse.emf.ecore_2.1.0.jar,file:/opt/LumaQQ/lib/org.eclipse.emf.common_2.1.0.j ar,file:./,file:/opt/LumaQQ/lib/org.eclipse.core.runtime_3.1.0.jar,file:/opt/Lum aQQ/lib/org.eclipse.core.resources_3.1.0.jar,file:./,file:/opt/LumaQQ/lib/lumaqq _xsd.jar,file:/opt/LumaQQ/lib/lumaqq_template.jar,file:./,file:/opt/LumaQQ/lib/l umaqq.jar,file:/opt/LumaQQ/lib/log4j-1.2.8.jar,file:./,file:/opt/LumaQQ/lib/jql_ protocol.jar,file:/opt/LumaQQ/lib/jql_net.jar,file:./,file:/opt/LumaQQ/lib/je.ja r,file:/opt/LumaQQ/lib/jdom.jar,file:./,file:/opt/LumaQQ/lib/commons-logging.jar ,file:/opt/LumaQQ/lib/commons-codec.jar,file:./], parent=gnu.gcj.runtime.Extensi onClassLoader{urls=[], parent=null}}
at ._ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE (/usr/lib/l ibgcj.so.6.0.0)
at ._ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ThrowableC1EPNS0_6StringEPS1_ (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ExceptionC1EPNS0_6StringEPNS0_9ThrowableE (/usr/lib/libgcj. so.6.0.0)
at ._ZN4java4lang22ClassNotFoundExceptionC1EPNS0_6StringEPNS0_9ThrowableE (/u sr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang22ClassNotFoundExceptionC1EPNS0_6StringE (/usr/lib/libgcj.so .6.0.0)
at ._ZN4java3net14URLClassLoader9findClassEPNS_4lang6StringE (/usr/lib/libgcj .so.6.0.0)
at ._ZN4java4lang11ClassLoader9loadClassEPNS0_6StringEb (/usr/lib/libgcj.so.6 .0.0)
at ._ZN4java4lang11ClassLoader9loadClassEPNS0_6StringE (/usr/lib/libgcj.so.6. 0.0)
at ._Z13_Jv_FindClassP13_Jv_Utf8ConstPN4java4lang11ClassLoaderE (/usr/lib/lib gcj.so.6.0.0)
at ._ZN4java4lang5Class7forNameEPNS0_6StringEbPNS0_11ClassLoaderE (/usr/lib/l ibgcj.so.6.0.0)
at ._ZN20_Jv_BytecodeVerifier21verify_instructions_0Ev (/usr/lib/libgcj.so.6. 0.0)
at ._Z16_Jv_VerifyMethodP16_Jv_InterpMethod (/usr/lib/libgcj.so.6.0.0)
at ._ZN21_Jv_InterpreterEngine9do_verifyEPN4java4lang5ClassE (/usr/lib/libgcj .so.6.0.0)
at ._ZN10_Jv_Linker12verify_classEPN4java4lang5ClassE (/usr/lib/libgcj.so.6.0 .0)
at ._ZN10_Jv_Linker14wait_for_stateEPN4java4lang5ClassEi (/usr/lib/libgcj.so. 6.0.0)
...8 more
回复

回到 “老旧版本支持”