刷新率问题,急,求助[解决]

为当前最终发行版之前的所有版本提供支持
回复
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

刷新率问题,急,求助[解决]

#1

帖子 Rexmagnus » 2006-04-14 13:47

前两天apt-get dist-upgrade以后,刷新率无论如何就上不去85了。而以前是完全没有问题的。
请各位看看,是什么问题? (Sempron 2500+, 1.5GB, NV 6100)


我的xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Mar 29 14:43:26 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# paths to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"


Identifier "PHILIPS 107F"
HorizSync 31.0 - 101.0
VertRefresh 60.0 - 160.0
Option "DPMS"
ModeLine "1024x768_85.00" 94.4 1024 1088 1200 1376 768 769 772 807 -hsync +vsync
EndSection

Section "Device"
Identifier "NVIDIA Corporation NVIDIA Default Card"
Driver "nvidia"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NVIDIA Default Card"
Monitor "PHILIPS 107F"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
EndSection

PS,即时把其中的“ModeLine "1024x768_85.00" 94.4 1024 1088 1200 1376 768 769 772 807 -hsync +vsync" 或者除1024x768以外的分辨率都去掉。还是没有用。GNOME中最高只有70,看着眼睛痛!
上次由 Rexmagnus 在 2006-04-14 19:09,总共编辑 1 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-04-14 14:20

还不如搜索论坛。xresprobe
● 鸣学
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

#3

帖子 Rexmagnus » 2006-04-14 14:29

xresprobe nvidia

返回的是空信息

xresprobe nv
也一样
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-04-14 14:37

不知道加 load 'dri' 会不会产生信息。
● 鸣学
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

#5

帖子 Rexmagnus » 2006-04-14 14:41

DRI会影响刷新率吗?那我把他加上试试看

不过照道理,NVIDIA的驱动,要求把这个去掉的吧

以前好好的,更新以后就不行了。不知道是不是Bug
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

#6

帖子 Rexmagnus » 2006-04-14 15:10

it just doesn't work
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

我的多了几行。才发现。你干脆dpkg-reconfigure xserver-xorg搞下。

#7

帖子 eexpress » 2006-04-14 15:21

SubSection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
● 鸣学
GPX-ZERO
帖子: 38
注册时间: 2005-08-04 14:37
来自: 中国香港
送出感谢: 0
接收感谢: 0

#8

帖子 GPX-ZERO » 2006-04-14 16:28

应该可以的...
把先前的ModeLine行注释掉, 然后贴上下面代码产生的结果 :!:另外要注意位置不可以贴错

代码: 全选

wget http://osdn.dl.sourceforge.net/sourceforge/gtf/gtf.c && gcc gtf.c -o gtf -lm -Wall && ./gtf 1024 768 85
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

#9

帖子 Rexmagnus » 2006-04-14 17:01

楼上的,谢谢,正确的位置应该在哪里?

另,按照eexpress说的加上
Section "DRI"
Mode 0666
EndSection

后,还是不行。不过如果我把nvidia换成nv的话。刷新率可以达到79 (虽然GNOME里说是85)
GPX-ZERO
帖子: 38
注册时间: 2005-08-04 14:37
来自: 中国香港
送出感谢: 0
接收感谢: 0

#10

帖子 GPX-ZERO » 2006-04-14 17:12

在Section "Monitor"至最接近EndSection的行間內
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

#11

帖子 Rexmagnus » 2006-04-14 17:26

还是不行 :( :( :( :( :( :(
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2006-04-14 19:07

不行就进recovery mode, dpkg-reconfigure xserver-xorg
● 鸣学
Rexmagnus
帖子: 7
注册时间: 2006-04-14 13:40
送出感谢: 0
接收感谢: 0

#13

帖子 Rexmagnus » 2006-04-14 19:08

研究了下Nvidia的官方论坛。是8756驱动的问题
把 Depth 24
Modes "1024x768"
EndSubSection
EndSection

改为
Modes "1024x768_85"
EndSubSection
EndSection

就可以了
joe45
帖子: 87
注册时间: 2006-03-21 3:03
送出感谢: 0
接收感谢: 0

#14

帖子 joe45 » 2006-04-15 4:00

ATI 可以么?

把 Depth 24
Modes "1024x768"
EndSubSection
EndSection

改为
Modes "1024x768_85"
EndSubSection
EndSection

就可以了
回复

回到 “老旧版本支持”