8.04+A69G主板,声卡尝试过N种方法都无法安装成功,继续更新中.(已能找到声卡)

为当前最终发行版之前的所有版本提供支持
回复
lhtoo
帖子: 60
注册时间: 2007-09-24 22:28
送出感谢: 0
接收感谢: 0

8.04+A69G主板,声卡尝试过N种方法都无法安装成功,继续更新中.(已能找到声卡)

#1

帖子 lhtoo » 2008-06-18 2:45

这板子必须修改BIOS设置
进入BIOS,打开Integrated,进入South onchip选项,把HDMI Azaliz Audio设置成 Enabled,把ATI AC 97Audio也要设置成Auto。保存进入系统后声卡就能被识别了。


.修改atiixp.c
#cd alsa-driver-1.0.16
#gedit alsa-kernel/pci/atiixp.c
在290行左右有一个结构
static struct pci_device_id snd_atiixp_ids[] = {
{ 0x1002, 0x4341, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB200 */
{ 0x1002, 0x4361, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB300 */
{ 0x1002, 0x4370, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB400 */
{ 0, }
};
加一行,成如下
static struct pci_device_id snd_atiixp_ids[] = {
{ 0x1002, 0x4341, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB200 */
{ 0x1002, 0x4361, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB300 */
{ 0x1002, 0x4370, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB400 */
{ 0x1002, 0x4382, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0 }, /* SB600 */
{ 0, }
};
保存退出

编辑安装了driver,lib.utils

sudo alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or directory

这是怎么回事?

试过如下方法了:
首先我建议先用源里的驱动

1. 如果你已经试了好多种方法,系统设置已经乱了,建议把声卡相关驱动全部删除,然后重新安装。

删除alsa
代码:
sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils


重新安装alsa
代码:
sudo apt-get install linux-sound-base alsa-base alsa-utils


****注意****
这一步很重要,在删除alsa-utils的时候会同时删除gdm和ubuntu-desktop,意味着将失去桌面,所以得重新安装桌面
代码:
sudo apt-get install gdm ubuntu-desktop


无论用源里的,还是官方下载编译安装的,均无法运行alsamixer,希望有经验的能帮忙解决一下。
整了一个晚上,论坛里百度上都搜遍了。。。

lspci -v|grep audi
00:14.5 Multimedia audio controller: ATI Technologies Inc SB600 AC97 Audio
上次由 lhtoo 在 2008-06-19 9:27,总共编辑 1 次。
头像
laowu2141
帖子: 530
注册时间: 2007-06-19 11:25
系统: kubuntu 13.04
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 laowu2141 » 2008-06-18 9:40

首先要说的是,我已经放弃A690G的主板上装linux了,又换回了原来的NV C51PV的板子,虽然老点,但是运行fusion比那个690G快多了,流畅多了。
然后要说的是,我当时在690G的板子上装ubuntu 7.10的时候,刚开始好像是有声音的,后来也不知道怎么搞的就没声了,也就没管他,反正那个板子我也不想用来装linux,也就没有解决办法了。
那快690G的板子,现在让我装上VISTA给我妈用了!


打搅了!
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

#3

帖子 hcym » 2008-06-18 9:46

:shock:

太客气了
回复

回到 “老旧版本支持”