sudo apt-get install build-essential错误

为当前最终发行版之前的所有版本提供支持
回复
jily527
帖子: 3
注册时间: 2007-09-19 9:32
送出感谢: 0
接收感谢: 0

sudo apt-get install build-essential错误

#1

帖子 jily527 » 2008-06-24 15:30

jily@jilytang:~$ sudo apt-get install build-essential
[sudo] password for jily:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装
E: 无法安装的软件包
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2008-06-24 15:40

检查你的源和你的系统版本是否一致
关注我的blog: ε==3
回复

回到 “老旧版本支持”