当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 中文相关设置已经完成了,但是有些情况下会这样
帖子发表于 : 2006-04-17 22:47 

注册: 2006-04-13 21:56
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
第一个图片是美化好的 使用的是wqy的字体
第二个是现在出的问题 中文无法正常显示

这样的现象还出现在登陆界面 输入的用户名 密码无法显示(这下可够安全了 连用户名别人也看不到了) 能显示输入的字符占的位置

幸好论坛能访问-_-b

出现类似情况是在/etc/fonts/增加了一个local.conf的文件之后(xml格式,忘了在什么地方看到的)
添加了这个文件之后所有新创建的窗口都无法正常显示(菜单栏能看到快捷键 但是没菜单名)
之后重新启动 看起来还是老样子(登录界面有些字也无法正常显示) 只好使用英文的会话 进去之后将local.conf删除掉
(由于是root的文件,所以还需要在命令行下输入 想不到命令行也无法显示 全黑的 能看到光标的位置 盲打了sudo -s -> [input pass] -> rm /etc/fonts/local.conf)
然后重新启动 想不到界面字体变了 高兴ing 但是输入用户名竟然不显示 只显示位置.. 之后就是上面说的和贴图了

我之前还设置过LC_ALL(在gedit /etc/environment 来自[快速设置指南])


因为到wqy官方看设置方法 想不到论坛中就有 结果绕了大弯了


附件:
文件注释: 中文无法正常显示
Screenshot-1.png
Screenshot-1.png [ 148.62 KiB | 被浏览 471 次 ]

文件注释: 使用wqy的中文字体,也忘了到底试过哪些设置方法了
Screenshot.png
Screenshot.png [ 80.74 KiB | 被浏览 453 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-04-18 1:05 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
盲打 :lol:


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-04-18 20:20 

注册: 2006-04-13 21:56
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
盲打 :lol:

这个是以前看一个hack教程中 telnet到http服务器上 然后盲打(输入的内容就是http请求了)

我贴的情况怎么解释?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-18 21:45 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
搞不懂啊。说不定是看了我的帖子。听irc的说local.conf被废除了。我现在的hint和antialias是设置在~/.fonts.conf里面。你试试。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-19 8:15 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
这个问题好奇怪啊,没有碰到过.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译