[问题]conexant usb adsl 在ubuntu下和在rhfc3下有什么不同?

为当前最终发行版之前的所有版本提供支持
回复
头像
蝴蝶兰
帖子: 202
注册时间: 2006-04-18 10:13
来自: china
送出感谢: 0
接收感谢: 0
联系:

[问题]conexant usb adsl 在ubuntu下和在rhfc3下有什么不同?

#1

帖子 蝴蝶兰 » 2006-04-19 20:31

我以前的猫是上海贝电的USB接口的ADSL,系统是rhfc3,下载cxacru.tar.bz2后自己修改了源程序,编译后一直能够正常驱动和上网。我现在的猫是万利达的MAU201 USB接口的ADSL,芯片还是conexant,用同样的程序却只能正常驱动(我想是的),拨号时总是超时!
我最近安装了ubuntu5.10,重新下载了cxacru.tar.bz2,编译后(我改了系统里的某个东西,否则也无法正常编译)执行cxstart.sh后报错失败:
>>> Inits Conexant AccessRunner <<<

>>> Loading firmware...

Conexant AccessRunner microcode upload program. 6/9/2003

Josep Comas <jcomas at gna.es>

See credits in documentation

I found ADSL modem with VendorID = 0572 & ProductID = cb00

Loading and sending /usr/sbin/cxfirm4.bin...

Firmware is sent!

Setting configuration...

Waiting ADSL line is up (until 90 seconds)...

...............

ADSL line is up (Downstream 1024 Kbits/s, Upstream 640 Kbits/s)

>>> Loading driver...

FATAL: Module crc32 not found.

Launching driver in normal mode...

FATAL: Error inserting cxacru
(/lib/modules/2.6.12-9-386/kernel/drivers/usb/cxacru.ko): Invalid module format


这是执行到脚本里的modprobe $MODULE_RUN speed=$SPEED_OPTION open=$PARAM_0a || exit 1
的时候报错。这应该是加载cxacru.ko这个模块时出的错。
请各位大侠帮忙!
(谢绝沽名钓誊者跟贴!以免浪费我和遇到同样问题的朋友们的感情!)
头像
蝴蝶兰
帖子: 202
注册时间: 2006-04-18 10:13
来自: china
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 蝴蝶兰 » 2006-04-24 14:17

:( :evil: :cry: 我的问题是不是太菜了?!怎么没人理我啊!这么多天了~~~~~~~~
我改动过的地方:/lib/modules/2.6.12.9-386/build/Makefile文件中的CC我改为了gcc-4.0,HOSTCC也改为了gcc-4.0。
在/var/log/messages中有这样的内容:usb.agent[7604]: cxacru: can't be loaded.missing kernel or user mode driver cxacru
哪位明眼的师傅给帮一下忙,让我这只越老越菜的老菜鸟早日抛弃Windows,在Linux下上网!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2006-04-24 15:53

usb的吧。是麻烦写。主要是看驱动下载地方的说明和包内的说明。没统一的方法。
我用过2款。你参考下
http://forum.ubuntu.org.cn/weblog_entry.php?e=213
http://forum.ubuntu.org.cn/weblog_entry.php?e=13
后来这2款都加入了源的。那还是hoary版本。后来breezy版本就有一款驱动不兼容了。现在用dapper,似乎驱动又好些了。但现在换了个eth0的。所以没去搞这些了。

你的这款记得以前rpm的说明很多。应该也有deb的说明的。
● 鸣学
头像
蝴蝶兰
帖子: 202
注册时间: 2006-04-18 10:13
来自: china
送出感谢: 0
接收感谢: 0
联系:

谢谢楼上

#4

帖子 蝴蝶兰 » 2006-04-25 17:30

非常感谢楼上。昨天我中病毒了。所以没及时上来,今天才看到。
WINDOWSXP就是脆弱!C:\t.inx是个病毒啊!用金山毒霸居然没查出来,任务管理器也被禁用了,我的XP和金山还都是正版的!今天好了,我手工清除掉这个病毒了 :D
头像
蝴蝶兰
帖子: 202
注册时间: 2006-04-18 10:13
来自: china
送出感谢: 0
接收感谢: 0
联系:

问题的关键

#5

帖子 蝴蝶兰 » 2006-05-13 14:29

现在我明白了,其实在哪个发行版下都一样,用哪种驱动都无所谓,问题的关键在于pppoe的几个配置文件。
回避问题 = 曲线救国 = 棒槌
回复

回到 “老旧版本支持”