utuntu用那个gcc版本比较好,怎么更换gcc版本

为当前最终发行版之前的所有版本提供支持
回复
believefym
帖子: 67
注册时间: 2006-01-10 23:03
送出感谢: 0
接收感谢: 0

utuntu用那个gcc版本比较好,怎么更换gcc版本

#1

帖子 believefym » 2006-04-23 10:13

默认的4。0好像不是太好
demonseyes
帖子: 22
注册时间: 2005-04-13 22:06
送出感谢: 0
接收感谢: 0

#2

帖子 demonseyes » 2006-04-25 23:38

那就用3.4
pointer
帖子: 5
注册时间: 2006-04-17 12:56
送出感谢: 0
接收感谢: 0

#3

帖子 pointer » 2006-04-26 14:05

装上gcc-3.4,
以后手动将gcc-3.4链结到gcc即可
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-04-26 14:25

越高版本越好了。除开你编译什么,需要指定版本。
● 鸣学
头像
myfavourite
帖子: 55
注册时间: 2006-04-24 14:20
送出感谢: 0
接收感谢: 0

#5

帖子 myfavourite » 2006-04-26 16:30

pointer 写了:装上gcc-3.4,
以后手动将gcc-3.4链结到gcc即可
我gcc-3.4与gcc-4.*都装了

顺便问一下如何手动链结?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-04-26 16:37

ln -s gcc-3.4 /usr/bin/gcc

$ ll /usr/bin/gcc
lrwxrwxrwx 1 root root 7 2006-03-30 11:44 /usr/bin/gcc -> gcc-4.0
● 鸣学
回复

回到 “老旧版本支持”