当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装驱动出问题,请哪位帮忙看看(2)(已解决)
帖子发表于 : 2006-04-23 14:50 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
mimihu88@ubuntumimihu:/tmp/alsa-driver-1.0.11$ make
make all-deps
make[1]: Entering directory `/tmp/alsa-driver-1.0.11'
utils/mod-deps --basedir /tmp/alsa-driver-1.0.11/alsa-kernel --hiddendir /tmp/alsa-driver-1.0.11 --acinclude > acinclude.m4
make[1]: Leaving directory `/tmp/alsa-driver-1.0.11'

Please, run the configure script as first...

mimihu88@ubuntumimihu:/tmp/alsa-driver-1.0.11$ make install
rm -f /snd*.*o /persist.o /isapnp.o
make[1]: Entering directory `/tmp/alsa-driver-1.0.11/acore'
Makefile:6: /tmp/alsa-driver-1.0.11/Makefile.conf: 没有那个文件或目录
/tmp/alsa-driver-1.0.11/Rules.make:75: /Rules.make1: 没有那个文件或目录
make[1]: *** 没有规则可以创建目标“/Rules.make1”。 停止。
make[1]: Leaving directory `/tmp/alsa-driver-1.0.11/acore'
make: *** [install-modules] 错误 1


最后由 mimihu88 编辑于 2006-04-23 16:58,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-04-23 14:55 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
alsa,系统安装就有的吧。
编译要先自己看熟悉,安装了编译环境,再用的。你.configure都没搞就make


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:03 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
eexpress 写道:
alsa,系统安装就有的吧。
编译要先自己看熟悉,安装了编译环境,再用的。你.configure都没搞就make


./configure搞了的!!!系统带的驱动版本低,反正现在是没声音,说不定升级一下驱动会好呢,不懂就是要折腾,
否则永远都不会,大不了重装系统吗

mimihu88@ubuntumimihu:~$ cd /tmp/alsa-driver-1.0.11
mimihu88@ubuntumimihu:/tmp/alsa-driver-1.0.11$ ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /tmp/alsa-driver-1.0.11
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel linux/version.h... no
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).
mimihu88@ubuntumimihu:/tmp/alsa-driver-1.0.11$ make
make all-deps
make[1]: Entering directory `/tmp/alsa-driver-1.0.11'
utils/mod-deps --basedir /tmp/alsa-driver-1.0.11/alsa-kernel --hiddendir /tmp/alsa-driver-1.0.11 --acinclude > acinclude.m4
make[1]: Leaving directory `/tmp/alsa-driver-1.0.11'

Please, run the configure script as first...

mimihu88@ubuntumimihu:/tmp/alsa-driver-1.0.11$ make install
rm -f /snd*.*o /persist.o /isapnp.o
make[1]: Entering directory `/tmp/alsa-driver-1.0.11/acore'
Makefile:6: /tmp/alsa-driver-1.0.11/Makefile.conf: 没有那个文件或目录
/tmp/alsa-driver-1.0.11/Rules.make:75: /Rules.make1: 没有那个文件或目录
make[1]: *** 没有规则可以创建目标“/Rules.make1”。 停止。
make[1]: Leaving directory `/tmp/alsa-driver-1.0.11/acore'
make: *** [install-modules] 错误 1


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:07 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).

./configure的时候就有问题了,是不是版本头的问题啊


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:20 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
$ ll /usr/bin/gcc
lrwxrwxrwx 1 root root 7 2006-03-28 20:58 /usr/bin/gcc -> gcc-4.0
你把这个删除,再sudo ln -s一个希望的版本试试。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:25 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
eexpress 写道:
$ ll /usr/bin/gcc
lrwxrwxrwx 1 root root 7 2006-03-28 20:58 /usr/bin/gcc -> gcc-4.0
你把这个删除,再sudo ln -s一个希望的版本试试。


你的意思是gcc版本不对?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:30 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
mimihu88@ubuntumimihu:~$ ln -s /usr/bin/gcc-3.4 /usr/bin/gcc
ln: ‘/usr/bin/gcc’:文件已存在


这又是什么意思?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:32 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
仔细看。上面说了,先把gcc删除。再sudo ln -s


_________________
● 鸣学


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:44 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
eexpress 写道:
仔细看。上面说了,先把gcc删除。再sudo ln -s


bash: lrwxrwxrwx: command not found

直接卸载gcc 4.0 行不行,应该怎么卸载


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-04-23 15:50 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你那是什么哦。是权限标记了。

sudo rm /usr/bin/gcc
sudo ln -s /usr/bin/gcc-3.4 /usr/bin/gcc


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-04-23 16:05 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).

./configure的时候还是一样的问题

我的/usr/src/里面是空的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译