[问题]RPM安装的问题

为当前最终发行版之前的所有版本提供支持
回复
switch
帖子: 83
注册时间: 2006-04-24 20:29
送出感谢: 0
接收感谢: 0

[问题]RPM安装的问题

#1

帖子 switch » 2006-04-26 10:15

下了一个RAR安装包,rar-3.5-0.b1.2.el4.rf.i586.rpm,输入下面的命令,安装不了,是什么意思?
RPM包我已经安装过,输入:rpm --help可以看到帮助信息。
用LINUX两天了,还没成功的用RPM,TAR安装过软件,真失败
alien也安装上了

代码: 全选

route@wpro:~$ rpm -ivh rar-3.5-0.b1.2.el4.rf.i586.rpm
rpm: To install rpm packages on Debian systems, use alien. See README.Debian.
error: cannot open Packages index using db3 - 没有那个文件或目录 (2)
error: cannot open Packages database in /var/lib/rpm
lglinger
帖子: 19
注册时间: 2006-04-24 18:11
来自: 福建
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 lglinger » 2006-04-26 13:35

呵呵 Ubuntu是使用deb包的
rpm是红帽的软件包格式
想安装的话你必须用alien来转换
sudo apt-get install alien
sudo alien *.rpm
sudo dpkg -i *.deb
好像用ailen可以一次搞定
但我觉得还是一步一步来比较好
呵呵
switch
帖子: 83
注册时间: 2006-04-24 20:29
送出感谢: 0
接收感谢: 0

#3

帖子 switch » 2006-04-26 17:00

谢谢
那想卸载这些软件用什么命令啊?
回复

回到 “老旧版本支持”