[问题]什么都是这样?!(问题已经解决)

为当前最终发行版之前的所有版本提供支持
回复
myboob
帖子: 11
注册时间: 2005-12-04 7:01
送出感谢: 0
接收感谢: 0
联系:

[问题]什么都是这样?!(问题已经解决)

#1

帖子 myboob » 2006-04-26 16:21

下列【新】软件包将被安装:
gstreamer0.8-visuals
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 113 个软件未被升级。
有 40 个软件包没有被完全安装或卸载。
需要下载 0B/63.0kB 的软件包。
解压缩后会消耗掉 176kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过认证!
gstreamer0.8-visuals
不经验证就安装这些软件包么?[y/N] y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 58711 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)

您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
scim: 依赖: libscim8 但是它将不会被安装
scim-input-pad: 依赖: libscim8 但是它将不会被安装
scim-modules-socket: 依赖: libscim8 但是它将不会被安装
scim-modules-table: 依赖: libscim8 但是它将不会被安装
scim-pinyin: 依赖: libscim8 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
root@ubuntu:/home/dongyu# $sudo sh -c " echo 'export XMODIFIERS=@im=SCIM ; export GTK_IM_MODULE="scim" ; scim -d ' > /etc/X11/Xsession.d/95xinput "
root@ubuntu:/home/dongyu# $sudo chmod +755 /etc/X11/Xsession.d/95xinput
上次由 myboob 在 2006-04-26 18:03,总共编辑 1 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-04-26 16:42

搜索update和upgrade
● 鸣学
myboob
帖子: 11
注册时间: 2005-12-04 7:01
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 myboob » 2006-04-26 16:55

zhao bu dao
myboob
帖子: 11
注册时间: 2005-12-04 7:01
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 myboob » 2006-04-26 16:58

zhao dao le zm jiejue xianzai shenmo ye ganbu liao
myboob
帖子: 11
注册时间: 2005-12-04 7:01
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 myboob » 2006-04-26 17:04

#!/bin/bash
set -e

# Set the textdomain for the translations using $"..."
TEXTDOMAIN="apt"

# Get the configuration from /etc/apt/apt.conf
CLEAN="prompt"
OPTS="-f"
APTGET="/usr/bin/apt-get"
APTCACHE="/usr/bin/apt-cache"
DPKG="/usr/bin/dpkg"
DPKG_OPTS="--admindir=$1"
APT_OPT0="-oDir::State::status=$1/status"
APT_OPT1="-oDPkg::Options::=$DPKG_OPTS"
CACHEDIR="/var/cache/apt"
PROMPT="false"
RES=`apt-config shell CLEAN DSelect::Clean OPTS DSelect::UpdateOptions \
DPKG Dir::Bin::dpkg/f APTGET Dir::Bin::apt-get/f \
APTCACHE Dir::Bin::apt-cache/f CACHEDIR Dir::Cache/d \
PROMPT DSelect::PromptAfterUpdate/b`
eval $RES

# It looks slightly ugly to have a double / in the dpkg output
CACHEDIR=`echo $CACHEDIR | sed -e "s|/$||"`

STATUS=1
if $APTGET $OPTS "$APT_OPT0" "$APT_OPT1" update
then
echo $"Merging available information"
rm -f $CACHEDIR/available
$APTCACHE dumpavail > $CACHEDIR/available
$DPKG "$DPKG_OPTS" --update-avail $CACHEDIR/available
rm -f $CACHEDIR/available

case "$CLEAN" in
Pre-Auto|PreAuto|pre-auto)
$APTGET "$APT_OPT0" "$APT_OPT1" autoclean;;
esac

STATUS=0
fi

if [ x$PROMPT = "xtrue" ]; then
echo $"Press enter to continue." && read RES;
fi

exit $STATUS
leon_zhu
帖子: 5
注册时间: 2006-05-04 0:48
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 leon_zhu » 2006-05-05 14:56

看不懂,你这段代码是干什么的,
还有把它放在哪???
现谢了。
feixu911
帖子: 53
注册时间: 2006-04-21 18:31
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 feixu911 » 2006-05-05 18:32

你先安装一下解码器。试一下。看一下“非官方新手入门指南”-》“新增其他应用程序”就知道了
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#8

帖子 Element » 2006-05-05 19:04

apt-get -f install gstreamer0.8-plugins

强行安装。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
回复

回到 “老旧版本支持”