[问题]按照快速设置指南里面的做法出错

为当前最终发行版之前的所有版本提供支持
回复
贪玩的风筝
帖子: 3
注册时间: 2006-04-29 17:48
送出感谢: 0
接收感谢: 0

[问题]按照快速设置指南里面的做法出错

#1

帖子 贪玩的风筝 » 2006-04-29 17:51

mark@ubuntu:~$ sudo apt-get install beep-media-player totem-xine w32codecs gstreamer0.8-plugins
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
beep-media-player 已经是最新的版本了。
totem-xine 已经是最新的版本了。
w32codecs 已经是最新的版本了。
gstreamer0.8-plugins 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
mark@ubuntu:~$ sudo apt-get install beep-media-player totem-xine w32codecs gstreamer0.8-plugins
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
beep-media-player 已经是最新的版本了。
totem-xine 已经是最新的版本了。
w32codecs 已经是最新的版本了。
gstreamer0.8-plugins 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
mark@ubuntu:~$ sudo apt-get -f install beep-media-player totem-xine w32codecs gstreamer0.8-plugins
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
beep-media-player 已经是最新的版本了。
totem-xine 已经是最新的版本了。
w32codecs 已经是最新的版本了。
gstreamer0.8-plugins 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
mark@ubuntu:~$ sudo apt-get -f install gstreamer0.8-visuals 正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列【新】软件包将被安装:
gstreamer0.8-visuals
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 117 个软件未被升级。
有 40 个软件包没有被完全安装或卸载。
需要下载 0B/63.0kB 的软件包。
解压缩后会消耗掉 176kB 的额外空间。
【警告】:下列的软件包不能通过认证!
gstreamer0.8-visuals
不经验证就安装这些软件包么?[y/N] y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 59779 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)

这个包还会影响到之后的其他软件的安装 所以我特来论坛求助,谢谢
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#2

帖子 Element » 2006-04-29 22:32

好像要安装0.8.11-0unofficialubuntu3_i386.deb
今天我升级的时候也遇到了这个问题,最后也是强制安装才过去的。
还要安装gstreamer0.8-misc,我今天就是强制安装这个包的。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
g2.0
帖子: 110
注册时间: 2005-06-09 21:30
来自: 河南
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 g2.0 » 2006-04-30 2:38

我也是这个毛病,我把交大的源注释掉了,用官方的。重启一次好了。
贪玩的风筝
帖子: 3
注册时间: 2006-04-29 17:48
送出感谢: 0
接收感谢: 0

#4

帖子 贪玩的风筝 » 2006-04-30 17:07

Element 写了:好像要安装0.8.11-0unofficialubuntu3_i386.deb
今天我升级的时候也遇到了这个问题,最后也是强制安装才过去的。
还要安装gstreamer0.8-misc,我今天就是强制安装这个包的。
请问要怎么安装0.8.11-0unofficialubuntu3_i386.deb这个包?我不知道怎么样直接下载deb包,请帮忙
至于gstreamer0.8-misc又要怎么安装呢?我输入apt-get install gstreamer0.8-misc 提示找不到
谢谢
贪玩的风筝
帖子: 3
注册时间: 2006-04-29 17:48
送出感谢: 0
接收感谢: 0

#5

帖子 贪玩的风筝 » 2006-04-30 17:09

g2.0 写了:我也是这个毛病,我把交大的源注释掉了,用官方的。重启一次好了。
我不是用交大的 我是用cn99的 不过我按照你的说法换成原来的地址也不行
tt7646
帖子: 163
注册时间: 2006-03-26 17:16
来自: 广东中山
送出感谢: 0
接收感谢: 0

#6

帖子 tt7646 » 2006-04-30 19:42

在新立得里面有一个gstreamer什么可以升级,你升级他,问题就可以解决了。昨天我也遇见这个情况~~


好运~ :D
回复

回到 “老旧版本支持”