当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教,如何安装ati 9200 se 的驱动,使其能支持3d?(参照论坛里的精华贴,没有成功,系统挂
帖子发表于 : 2006-04-30 10:34 

注册: 2006-04-25 20:00
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我参照了http://forum.ubuntu.org.cn/viewtopic.php?t=12110这篇文章,
可执行完
sudo apt-get install xorg-driver-fglrx
echo fglrx | sudo tee -a /etc/modules
sudo vi /etc/X11/xorg.conf
找到"ati"并将其改成"fglrx",

sudo reboot

这些命令后,输入
fglrxinfo

出现的是mesa,没有ati,应该是没有驱动成功吧。不能支持3d.
后来在论坛找了其他一些方法,结果系统挂了。重新设置了xserver-xorg才又进来的。

请教一下,这个ati 92000的驱动怎么才能搞定啊?我想玩玩xgl


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-05-04 1:31 
头像

注册: 2006-01-14 20:52
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
引用:
* ATI官方驱动安装配置指南

ATI fglrx 8.18.8 驱动安装配置指南

文章出处:wiki.ubuntu.com

适用版本:5.10

翻译人员:catinsnow

建议你只在碰到宽屏分辨率问题(使用8.16.20驱动)时才安装此驱动.随Breezy一起来的8.16.20驱动和这个驱动没有性能差异.

这个方法需要创建.deb文件然后安装驱动.你可以简单的通过运行.sh文件(译者注:实际上下载的驱动文件是.run结尾的)进入图形安装程序,前提是所有需要的东西都已经在正确的位置上.通过.deb安装关键的好处是:当错过什么时可以给你有用的错误提示,并且可以方便的缷载(用新力得).

重要警告:安装的这个驱动要正确工作需要缷裁restricted-modules包,这个包包含madwifi驱动(Atheros无线网卡),nvidia显卡驱动,和一些其它的设备驱动.我为madwifi做了工作,但你要在安装驱动之前做(跳到本篇的最后).
缷载旧驱动

如果安装了这些Breezy驱动,缷载它:

sudo apt-get remove xorg-driver-fglrx
sudo apt-get remove fglrx-control
sudo apt-get remove linux-restricted-modules-$(uname -r)
sudo dpkg-reconfigure xserver-xorg #Select the ATI driver

重启计算机.
安装新驱动

下载ATI驱动安装程序: https://support.ati.com/ics/support/def ... olderID=27

所有平台:

进入到下载目录(cd /path/to/directory).你安装过程中你可能会得到一些错误信息.可以忽略它,运行upgrade步骤时会解决. 译注:生成的deb文件应该在/tmp下.所以加了下面红色的代码.

sudo apt-get install gcc-3.4 module-assistant build-essential fakeroot dh-make debconf
sudo sh ./ati-driver-installer-8.18.8-i386.run --buildpkg Ubuntu/breezy
cd /tmp
sudo dpkg -i fglrx-control_8.18.8-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.18.8-1_i386.deb
sudo dpkg -i xorg-driver-fglrx_8.18.8-1_i386.deb
sudo apt-get -f upgrade

现在编译核心驱动:

sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant a-i fglrx

译注:如果出现错误

Package fglrx-kernel-source was not built successfully, see
/var/cache/modass/fglrx-kernel-source*buildlog* for details!

这样做:

cd /usr/src
sudo dpkg -i fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb

接着为fglrx驱动更新你的xorg.conf文件(有多个方法可以做到):

sudo aticonfig --initial

用64位系统的用户:

你将不得不把libdri.a文件降低到一个可以兼容这个ATI驱动的版本.在这里下载. http://mail3.mpr.org/mlomker/libdri.a.gz

进入下载目录:

gunzip libdri.a.gz
sudo cp /usr/X11R6/lib/modules/extensions/libdri.a libdri.a.old
sudo cp libdri.a /usr/X11R6/lib/modules/extensions/

如果你希望返回到非fglrx驱动,需要拷贝libdri.a.old文件覆盖这个fglrx兼容的版本.

所有平台:Ctrl-Alt-Backspace重启会话. 译注:有可能重启你的机器才能生效.

确认驱动工作正常:

mlomker@mlomkernote:/$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 1.3.5395 (X4.3.0-8.18.8)

问题解决:

用64位系统的用户

重启后你可能得到这样的错误:

Duplicate symbol rol_long in /usr/X11R6/lib/modules/drivers/fglrx_drv.o
Also defined in /usr/X11R6/lib/modules/linux/libint10.a

可以编辑你的xorg.conf文件,注释掉libint10.a行来解决它:

sudo nano /etc/X11/xorg.conf

Section "Module"
# Load "int10"
EndSection

Ctrl-X, Y, 回车存盘.

Madwifi驱动:

cd /lib/modules/$(uname -r)/volatile
sudo cp ath_hal.ko ../madwifi

UbuntuChina Wiki: ATI官方驱动安装配置指南 ((2006-03-20 10:35:21由firehare编辑))



呵呵 我就是按照这个来装的 我下载的是官方的最新版 ati-driver-installer-8.24.8-x86.run
你也可以去ATI官方下的 上面的只是参照 不要依葫芦画瓢 HOHO~ 祝你成功 。。。

http://wiki.ubuntu.org.cn/%E7%A1%AC%E4% ... D%97%29%29


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教,如何安装ati 9200 se 的驱动,使其能支持3d?(参照论坛里的精华贴,没有成功,系统挂
帖子发表于 : 2009-06-05 16:09 

注册: 2009-06-02 22:05
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我的是9250,在执行 以下命令时出现错误:


sh ./ati-driver-installer-8.28.8.run --buildpkg Ubuntu/breezy
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
-e ==================================================
-e ATI Technologies Linux Driver Installer/Packager
-e ==================================================
Generating package: Ubuntu/breezy
[: 182: breezy: unexpected operator
./packages/Ubuntu/ati-packager.sh: 182: pushd: not found
Package build failed!
Package build utility output:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
tail: cannot open `debian/changelog' for reading: No such file or directory
dpkg-buildpackage: failure: tail of debian/changelog gave error exit status 1
./packages/Ubuntu/ati-packager.sh: 182: popd: not found
Removing temporary directory: fglrx-install
帮忙给看一下,谢谢.................................


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译