求教?编译chmsee0.9的问题

为当前最终发行版之前的所有版本提供支持
回复
头像
jazzi
帖子: 532
注册时间: 2005-10-16 23:26
来自: 泉州
送出感谢: 0
接收感谢: 3 次
联系:

求教?编译chmsee0.9的问题

#1

帖子 jazzi » 2006-04-30 11:59

因为Dapper中还没有chmsee,只好自个儿下载源代码编译安装
./configure出现如下错误提示:
configure: error: Library requirements (libgtkhtml-3.1 >= 3.1.8) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
问题是我已经确认安装了libgtkhtml3.8-15和libgtkhtml3.8-dev,为什么还会出现libgtkhtml-3.1 >= 3.1.8没安装的提示???
You make it fun
It will make you fun
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#2

帖子 leal » 2006-04-30 12:40

设定 PKG_CONFIG_PATH 指向 那个库的路径 试试
用心×恒 | 豆瓣 | 门户 | Blog
头像
jazzi
帖子: 532
注册时间: 2005-10-16 23:26
来自: 泉州
送出感谢: 0
接收感谢: 3 次
联系:

#3

帖子 jazzi » 2006-04-30 13:46

我以前也遇到过这种问题,那时是dev文件没装,而提示中提到的那个文件是有装的
这次不知是怎么回事
You make it fun
It will make you fun
头像
jazzi
帖子: 532
注册时间: 2005-10-16 23:26
来自: 泉州
送出感谢: 0
接收感谢: 3 次
联系:

#4

帖子 jazzi » 2006-04-30 19:22

用chmsee的原因主要是它是针对中文的,对中文的显示解决了特别好,乱码是可自由选择合适的编码,相较于xchm,gnuchm等在中文支持方面明显技高一筹.
现在编译遇到了这个无厘头问题 :cry: :evil:
You make it fun
It will make you fun
xphenix
帖子: 35
注册时间: 2006-05-04 15:52
送出感谢: 0
接收感谢: 0

#5

帖子 xphenix » 2006-05-04 16:58

有一个很小的软件用来查看chm文档非常好。去www.linuxfans.org, 在自由软件里面下载 chmview,只有几十K,使用方法为 chmview your.chm
它的原理是将chm解析为html,然后调用浏览器浏览chm文档。如果你希望使用firefox浏览,只需要将chmview改名为chmview_fox即可。为方便使用,你可以设置chm文件的默认打开方式为chmview_fox。这个软件的显示效果非常好,是我见过最好的chm浏览器了。
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#6

帖子 Element » 2006-05-04 19:04

http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#7

帖子 bones7456 » 2006-05-08 19:45

xphenix 写了:有一个很小的软件用来查看chm文档非常好。去www.linuxfans.org, 在自由软件里面下载 chmview,只有几十K,使用方法为 chmview your.chm
它的原理是将chm解析为html,然后调用浏览器浏览chm文档。如果你希望使用firefox浏览,只需要将chmview改名为chmview_fox即可。为方便使用,你可以设置chm文件的默认打开方式为chmview_fox。这个软件的显示效果非常好,是我见过最好的chm浏览器了。
这个真的不错啊!
回复

回到 “老旧版本支持”