分页: 1 / 1

求教?编译chmsee0.9的问题

发表于 : 2006-04-30 11:59
jazzi
因为Dapper中还没有chmsee,只好自个儿下载源代码编译安装
./configure出现如下错误提示:
configure: error: Library requirements (libgtkhtml-3.1 >= 3.1.8) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
问题是我已经确认安装了libgtkhtml3.8-15和libgtkhtml3.8-dev,为什么还会出现libgtkhtml-3.1 >= 3.1.8没安装的提示???

发表于 : 2006-04-30 12:40
leal
设定 PKG_CONFIG_PATH 指向 那个库的路径 试试

发表于 : 2006-04-30 13:46
jazzi
我以前也遇到过这种问题,那时是dev文件没装,而提示中提到的那个文件是有装的
这次不知是怎么回事

发表于 : 2006-04-30 19:22
jazzi
用chmsee的原因主要是它是针对中文的,对中文的显示解决了特别好,乱码是可自由选择合适的编码,相较于xchm,gnuchm等在中文支持方面明显技高一筹.
现在编译遇到了这个无厘头问题 :cry: :evil:

发表于 : 2006-05-04 16:58
xphenix
有一个很小的软件用来查看chm文档非常好。去www.linuxfans.org, 在自由软件里面下载 chmview,只有几十K,使用方法为 chmview your.chm
它的原理是将chm解析为html,然后调用浏览器浏览chm文档。如果你希望使用firefox浏览,只需要将chmview改名为chmview_fox即可。为方便使用,你可以设置chm文件的默认打开方式为chmview_fox。这个软件的显示效果非常好,是我见过最好的chm浏览器了。

发表于 : 2006-05-04 19:04
Element

发表于 : 2006-05-08 19:45
bones7456
xphenix 写了:有一个很小的软件用来查看chm文档非常好。去www.linuxfans.org, 在自由软件里面下载 chmview,只有几十K,使用方法为 chmview your.chm
它的原理是将chm解析为html,然后调用浏览器浏览chm文档。如果你希望使用firefox浏览,只需要将chmview改名为chmview_fox即可。为方便使用,你可以设置chm文件的默认打开方式为chmview_fox。这个软件的显示效果非常好,是我见过最好的chm浏览器了。
这个真的不错啊!