当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu dapper 缺字严重呀
帖子发表于 : 2006-05-04 9:01 

注册: 2006-04-10 15:20
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
装了dapper beta2之后一路升级更新,刚开始都在配置一直也没有注意,昨天和别人聊Gaim发现很多中文都缺字呀。不知道默认安装的中文字体怎么样,会不会缺字。

我现在使用的是wiki里面推荐的圆体美化的,发现缺字以后我又安装了方正的字体,选择的是黑体,就是有2万多汉字的那几种,结果缺字依旧。

比如“en”这个拼音下看的最清楚了,居然“嗯”都没有。(这个帖子在win下写的)

各位大侠有没有什么好的解决办法?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-05-04 9:51 
头像

注册: 2005-10-16 13:24
帖子: 958
地址: 四川成都
送出感谢: 2
接收感谢: 0 次
没觉得缺字啊,我是用xfonts-wqy,安装好了就很不错了

嗯,呵呵


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-05-04 10:45 
头像

注册: 2005-11-22 12:59
帖子: 62
系统: Ubuntu 12.04
送出感谢: 0 次
接收感谢: 0 次
我是从5.1升级上去的,感觉也非常不错


页首
 用户资料  
 
4 楼 
 文章标题 : 下面是缺字的贴图
帖子发表于 : 2006-05-04 13:11 

注册: 2006-04-10 15:20
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
感觉太难受了


附件:
文件注释: 缺字的快照
Screenshot.png
Screenshot.png [ 437.17 KiB | 被浏览 503 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-05-07 19:02 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
试试重新生成locale:
代码:
sudo locale-gen zh_CN.UTF-8 zh_CN.GBK


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-05-07 22:32 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
我也是这样的情况,从breezy升到的dapper,重新生成locale的时候,如下:

代码:
song@ubuntu-song:/usr/bin$ sudo locale-gen zh_CN.UTF-8 zh_CN.GBK
Generating locales...
  zh_CN.GBK... tr: extra operand `w'
Try `tr --help' for more information.
done
  zh_CN.UTF-8... tr: extra operand `w'
Try `tr --help' for more information.
done
Generation complete.


仍旧和以前的情况(即楼主的情况)一样
:(


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-05-07 22:40 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
恩。没有口。flight 5新安装过来的。lz怎么发2个帖子了。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-05-08 0:05 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
nobrain 写道:
我也是这样的情况,从breezy升到的dapper,重新生成locale的时候,如下:

代码:
song@ubuntu-song:/usr/bin$ sudo locale-gen zh_CN.UTF-8 zh_CN.GBK
Generating locales...
  zh_CN.GBK... tr: extra operand `w'
Try `tr --help' for more information.
done
  zh_CN.UTF-8... tr: extra operand `w'
Try `tr --help' for more information.
done
Generation complete.


仍旧和以前的情况(即楼主的情况)一样
:(

好像有点异常,试试重装belocs-locales-bin和locales;系统->系统管理->Language support,选Chinese(China);然后
代码:
sudo dpkg-reconfigure locales


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-05-08 13:38 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
8楼的方法试过了,之后还把X重启了,但问题依旧。 :(


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-05-08 14:53 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
贴出你的/etc/fonts.conf,~/.fonts.conf或者你改过的其它字体配置文件.系统菜单字体对话框的截图.还有缺字是只在输入法才有还是在网页里也是.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-05-08 16:02 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
浏览网页没问题, 能看到“嗯”(从上面粘的),输入法有问题。


附件:
Screenshot-字体首选项.png
Screenshot-字体首选项.png [ 18.72 KiB | 被浏览 362 次 ]

文件注释: /etc/fonts/fonts.conf
/etc/fonts/local.conf
/etc/fonts/language-selector.conf

conf.tar.gz [4.37 KiB]
被下载 10 次


_________________
爱喝真猪奶茶的夜鸣猪
页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-05-12 1:01 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
几个建议:
把你的local.conf改名,那样处理黑体dapper中应该没有必要了;
fonts.conf里的字体顺序应该被language-selector.conf覆盖了,把它恢复原状:
代码:
 sudo cp /etc/fonts/fonts.conf.dpkg-dist /etc/fonts/fonts.conf

自定义顺序直接改language-selector.conf或者~/.fonts.conf,附上我的.fonts.conf,你放到家目录下试试;
字体首选项里不要直接选SimSun试试.


附件:
sample.tar [10 KiB]
被下载 10 次


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-05-12 18:04 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
fonts.conf.dpkg-dist 我找不到。看了新利得,fontconfig安装的文件里面也没有那个文件。

顺便说一下,我使用5.10光盘里的那个网络安装的文件,网络安装的,装好后发现不是dapper,又网上升到了dapper.
另外,字体配置文件里面的hinting是什么意思?


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译