已经装了高版本的软件包,怎样恢复成低版本的?

为当前最终发行版之前的所有版本提供支持
回复
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

已经装了高版本的软件包,怎样恢复成低版本的?

#1

帖子 nobrain » 2006-05-04 14:14

我把libgcc1换一个高版本的(源上没有),由于依赖关系的问题,想换成源上的低版本的,怎样处理? :(
爱喝真猪奶茶的夜鸣猪
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-05-04 15:06

高的完全卸载。
● 鸣学
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 nobrain » 2006-05-04 15:14

可是这样有一大堆的依赖关系问题,看着心里都发毛

我刚才用:
sudo dpkg --force-depends -P libc6

出现了什么错误不记得了,反正是低版本的依然不能装。
现在系统都进不去了。

就是为了装那个gnome-cn上的anjuta,把一些库换成了高版本的,现在…… :cry:
爱喝真猪奶茶的夜鸣猪
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-05-04 15:49

哇。我害的了。
送你一个bash。find-install-dpkg-group.sh libc6xxx这样的。只出一个提示,并不实际操作的。你要是删除了依赖的一堆软件,而其实并没有purge的话,安装的deb包还在,这个bash可以找出同时卸载的那些包,可以命令行下面把那些包再马上安装上。不过我记得,我安装anjuta时,似乎没这问题。

忘记了
grep '[0-9]\ install' /var/log/dpkg.log>tmp
中的install 改remove,就是找同时卸载的了。
附件
find-install-dpkg-group.sh.tar.gz
(544 Bytes) 下载 12 次
● 鸣学
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 nobrain » 2006-05-04 23:19

我是连recovery mode都进不去了,不过我现在已经重装,倒也清静了不少。那个shell script先收下了,以后说不定用得上 :)
爱喝真猪奶茶的夜鸣猪
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-05-07 16:01

● 鸣学
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 nobrain » 2006-05-12 23:06

比方说要卸叫“foolpak”的包

代码: 全选

sudo dpkg --ignore-depends=foolpak  -r foolpak
这样就可以只卸foolpak,而依赖于它的包将不会被卸载。
然后再安装低版本的包。

写在这里,希望其他人不要犯我的错误
上次由 nobrain 在 2006-10-14 22:32,总共编辑 1 次。
爱喝真猪奶茶的夜鸣猪
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2006-05-12 23:18

哦。这个倒是经验了。下次试试。 :lol:
● 鸣学
houri
帖子: 41
注册时间: 2005-12-28 1:16
送出感谢: 0
接收感谢: 0

#9

帖子 houri » 2006-10-06 16:22

用新立得菜单里的[软件包]->强制版本,可以降级,但是降级后可能会删除很多的包
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 BigSnake.NET » 2006-10-06 19:05

用新立德。。強制版本
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
musicx
帖子: 2
注册时间: 2006-06-16 10:09
送出感谢: 0
接收感谢: 0

#11

帖子 musicx » 2006-10-14 18:08

sudo dpkg --ignore-depents=foolpak
受教了,谢谢哈!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 BigSnake.NET » 2006-10-16 18:14

houri 写了:用新立得菜单里的[软件包]->强制版本,可以降级,但是降级后可能会删除很多的包
這是肯定的,魚與熊掌的問題..
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “老旧版本支持”