新手急问:安装问题

为当前最终发行版之前的所有版本提供支持
回复
xiaoyaofawai
帖子: 10
注册时间: 2006-05-07 14:08
送出感谢: 0
接收感谢: 0

新手急问:安装问题

#1

帖子 xiaoyaofawai » 2006-05-07 14:32

按照新手指南里的一步一步的做,不知道怎么错了,肯请帮忙看看

(正在读取数据库 ... 系统当前总共安装有 59291 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
xiaoyaofawai
帖子: 10
注册时间: 2006-05-07 14:08
送出感谢: 0
接收感谢: 0

#2

帖子 xiaoyaofawai » 2006-05-07 16:14

安装总是提示下面的错误:

下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

还有个问题文艺下:
timestamp too far in the future是什么错误?
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#3

帖子 Element » 2006-05-07 17:04

sudo apt-get -f install gstreamer0.8-plugins
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
xiaoyaofawai
帖子: 10
注册时间: 2006-05-07 14:08
送出感谢: 0
接收感谢: 0

#4

帖子 xiaoyaofawai » 2006-05-07 17:10

在新里的软件管理 里面把 gstreamer0.8-plugins给删了,不过又跳出来了一个问题
E: 无法获得锁 /var/lib/dpkg/lock - open
太郁闷了。。。。
xiaoyaofawai
帖子: 10
注册时间: 2006-05-07 14:08
送出感谢: 0
接收感谢: 0

#5

帖子 xiaoyaofawai » 2006-05-07 17:14

回3楼
整个过程是这样的


安装总是提示下面的错误:

下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

然后运行 sudo apt-get -f install

(正在读取数据库 ... 系统当前总共安装有 59291 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
tony988
帖子: 102
注册时间: 2006-04-16 15:48
送出感谢: 1 次
接收感谢: 0

#6

帖子 tony988 » 2006-05-25 8:54

E: 无法获得锁 /var/lib/dpkg/lock - open

=======================
出现上面的情况是因为你没关新立德

我是这怎样解决的,不知道对不对,总之出错的问题没有了:在新立德里把gstreamer-0.8 misc删除掉,然后再重新把它装上,不过删的时候提示说要同时删除另外几个程序,安装的时候这只安装它一个,不知道对系统有没有影响。大家都是菜鸟,一起来研究。
回复

回到 “老旧版本支持”