当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 编译内核遇到的问题请教
帖子发表于 : 2006-05-08 16:49 

注册: 2006-04-26 17:07
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
内核版本:linux-2.6.16.tar.bz2
编译过程:
mv linux-2.6.16.tar.bz2 /usr/src
tar jxvf linux-2.6.16.tar.bz2
ln -s linux linux-2.6.16
cd linux
make mrproper
make menuconfig
把LVS的支持选择上后,exit and save
make
make modules---出现一些提示说一些函数过时什么的,但是能够make过去
make modules_install
make install
最后,在/boot/grub的menu.list文件里添加
title ubuntu,kernel 2.6.16
root (hd0,0)
kernel /boot/vmlinuz-2.6.16 root=/dev/hda1
boot
默认的是这个:
title Ubuntu, kernel 2.6.12-10-386
root (hd0,0)
kernel /boot/vmlinuz-2.6.12-10-386 root=/dev/hda1 ro quiet splash
initrd /boot/initrd.img-2.6.12-10-386
savedefault
boot

重启后,选择新内核启动出错
VFS:cannot open root device "root=" or unknown-block(0,0)
please append a correct "root=" boot option
not syncing:unable to mount root fs on unknown-block(0,0)


大家帮忙


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-05-08 17:14 

注册: 2006-01-03 20:44
帖子: 869
送出感谢: 0 次
接收感谢: 6
你用的文件系统是什么,ext3抑或是reiserfs,有没有把文件系统编进内核,就是选Y而不能选M。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-05-08 17:32 

注册: 2006-04-26 17:07
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
好像是ext2?
我在grub启动选择里安C进入命令模式
输入root (hd0,0)
提示我说是ext2系统?
至于不能选M,到没有注意阿


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-05-08 18:41 

注册: 2006-01-03 20:44
帖子: 869
送出感谢: 0 次
接收感谢: 6
我分析的是有可能发生的一种情况。当然也许是其它问题。按理说生成了init.img文件了,是不必非得把文件系统编进内核,就是说也可编成模块。你可以先试在GRUB字符模式下调整一下内核分区位置,把boot改成具体的分区试试看。顺便说一句,ext3是ext2的扩展,一般编译内核时要把ext3也编进内核。
不过,我记得我在DEBIAN下编译内核时,用make install后,它会自动改写menu.lst的。当然,现在我在DEBIAN和UBUNTU下编译内核都是用make-kpkg kernel_image编成deb包再安装。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译