如何通过ssh登陆机器,sshd进程已开,就是登陆不上。

为当前最终发行版之前的所有版本提供支持
回复
field
帖子: 156
注册时间: 2005-05-31 19:32
送出感谢: 0
接收感谢: 0

如何通过ssh登陆机器,sshd进程已开,就是登陆不上。

#1

帖子 field » 2006-05-13 19:40

谢谢
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-05-13 19:45

自己不要开什么吧。登录别人的。

代码: 全选

$ dpkg -l *ssh*
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 当前状态=未(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)
|/ 错误?=(无)/保持(?)/须重装(R)/两者兼有(#) (状态,错误:大写=故障)
||/ 名称         版本         简介
+++-==============-==============-============================================
ii  openssh-client 4.2p1-7ubuntu1 Secure shell client, an rlogin/rsh/rcp repla
ii  openssh-server 4.2p1-7ubuntu1 Secure shell server, an rshd replacement
un  rssh           <无>          (无相关介绍)
un  ssh            <无>          (无相关介绍)
un  ssh-askpass    <无>          (无相关介绍)
ii  ssh-askpass-gn 4.2p1-7ubuntu1 under X, asks user for a passphrase for ssh-

代码: 全选

$ ps -A|grep ssh
 4707 ?        00:00:00 ssh-agent
这样的状态,对方建立一个帐号给你,你就可以登录了。当然对方要设置允许登录的。
● 鸣学
field
帖子: 156
注册时间: 2005-05-31 19:32
送出感谢: 0
接收感谢: 0

#3

帖子 field » 2006-05-14 17:24

现在就是不知道对方需要进行什么设置才能让我登陆,我可以ssh其它的机器,我这边没有问题。对方的sshd进程已经开了
大家都在同一个局域网内,可以telnet登陆对方机器,ssh不行
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-05-14 18:08

对方只要启动了。sudo /etc/init.d/ssh start。
配置文件只要改了这个。
/etc/ssh/sshd_config
# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no
● 鸣学
field
帖子: 156
注册时间: 2005-05-31 19:32
送出感谢: 0
接收感谢: 0

#5

帖子 field » 2006-05-14 21:03

按照楼主的方法做了,ChallengeResponseAuthentication yes
sudo /etc/init.d/ssh start 也成功了,可就是连不上阿
是不是机器的22端口被禁了阿? 怎么查看呢?
可能是防火墙的原因吗?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-05-14 21:49

你还是给个出错的提示吧。要不自己仔细看看提示。也许就好了。4楼说的可是服务端的做法啊。客户端的就直接ssh username@ip就可以了的。
● 鸣学
field
帖子: 156
注册时间: 2005-05-31 19:32
送出感谢: 0
接收感谢: 0

#7

帖子 field » 2006-05-14 22:11

我现在就是想在我的机器(192.9.201.55)上开ssh服务。按照4楼的做法做了
但是别的机器(192.9.201.53)怎么也登陆不了。
从别的机器上(192.9.201.53)用nmap扫描我机器的端口服务情况,
$nmap 192.9.201.55
Note: Host seems down. If it is really up, but blocking our ping probes, try -P0

$nmap 192.9.201.55 -P0显示如下:
All 1663 scanned ports on 192.9.201.55 are: filtered.

而在我的机器(192.9.201.55)上扫描192.9.201.53显示
$nmap 192.9.201.53
Interesting ports on 192.9.201.53:
(The 1658 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
22/tcp open ssh
512/tcp open exec
513/tcp open login
514/tcp open shell
6000/tcp open X11
所以我可以ssh到192.9.201.53上。

我的机器(192.9.201.55)安装过一次防火墙firewall,后来卸载了。不知道是不是firewall的问题。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2006-05-14 22:23

像。端口的这种情况不会设置了。不知道防火墙设置了些什么。要不找firehare的gtalk问,或者到irc.freenode.net/ubuntu-cn找帽子问。
● 鸣学
moonchild
帖子: 116
注册时间: 2005-12-25 20:44
送出感谢: 0
接收感谢: 0

#9

帖子 moonchild » 2006-05-17 16:29

不懂 帮顶


/etc/hosts.deny
iptables
有没有设置呢 ??
aloha
帖子: 375
注册时间: 2006-10-11 20:41
送出感谢: 0
接收感谢: 0

#10

帖子 aloha » 2007-01-29 23:25

/etc/ssh/sshd_config
把里面的
ListenAddress 0.0.0.0前面的#去掉
回复

回到 “老旧版本支持”