JAVA的jdk配置

为当前最终发行版之前的所有版本提供支持
回复
wjjcml1982
帖子: 38
注册时间: 2005-10-26 8:46
来自: China
送出感谢: 0
接收感谢: 0

JAVA的jdk配置

#1

帖子 wjjcml1982 » 2006-05-14 20:21

我想问一下ubuntu5.10可不可以装JDK1。4呢!为什么我装了j2dk1.4后,照着论坛上的配置后在终端运行 java-version,出现下面显示:
java version "1.4.2"
gij (GNU libgcj) version 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)

Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
我的jdk是j2sdk1.4.2_11的,我也不知道怎么回事了?eclipse也运行不起来阿!
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 madoldman » 2006-05-14 21:47

你是怎么安装的?ubuntu5.10好像自带了一个jre,就是你现在显示的这一个了,如果你是用deb包安装的jdk1.4,运行sudo update-alternatives --config java,选中你新装的这一个,如果你是用压缩包直接解压的,sudo unlink /usr/bin/java,然后把你新的jdk的bin目录加到PATH里面
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
wjjcml1982
帖子: 38
注册时间: 2005-10-26 8:46
来自: China
送出感谢: 0
接收感谢: 0

解决了!

#3

帖子 wjjcml1982 » 2006-05-15 7:51

谢谢,呵呵!用ubuntu的感觉不错!嘻嘻!
回复

回到 “老旧版本支持”