[问题]更新时候出错

为当前最终发行版之前的所有版本提供支持
回复
头像
liguang3333
帖子: 39
注册时间: 2006-03-26 1:05
送出感谢: 0
接收感谢: 0

[问题]更新时候出错

#1

帖子 liguang3333 » 2006-05-15 10:33

:( :( 每次更新都是这个怎么办?那位大虾帮帮忙

代码: 全选

hehe@ubuntu098:~/down$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级 。
有 3 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 cman (1.20060222-0ubuntu5) ...
FATAL: Module cman not found.
 Warning unable to load cman kernel moduleFATAL: Module dlm not found.
 Warning unable to load dlm kernel modulecman_tool: can't open /proc/cluster/sta tus, cman not running
Starting cluster managercman_tool: can't open /proc/cluster/status, cman not run ning
cman_tool: cannot connect to ccs (name=none)
invoke-rc.d: initscript cman, action "start" failed.
dpkg:处理 cman (--configure)时出错:
 子进程·post-installation script·返回了错误号·1
dpkg:依赖关系问题使得 fence 的配置工作不能继续:
 fence 依赖于 cman (= 1.20060222-0ubuntu5);然而:
  软件包 cman还没有被配置。
dpkg:处理 fence (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 clvm 的配置工作不能继续:
 clvm 依赖于 cman | gulm;然而:
  软件包 cman还没有被配置。
  软件包 gulm还没有被安装。
 clvm 依赖于 fence;然而:
  软件包 fence还没有被配置。
dpkg:处理 clvm (--configure)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 cman
 fence
 clvm
E: Sub-process /usr/bin/dpkg returned an error code (1)
:?: :?: :?:
xiulix
帖子: 6
注册时间: 2006-06-21 18:10
送出感谢: 0
接收感谢: 0

#2

帖子 xiulix » 2006-06-21 18:18

我也是同样的问题啊,
哪位哥哥,帮我一把阿
小弟在这里先谢谢了。
头像
守望伊人
帖子: 189
注册时间: 2006-05-18 18:24
来自: 四川广安
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 守望伊人 » 2006-06-21 18:29

删除掉clvm试试
xiulix
帖子: 6
注册时间: 2006-06-21 18:10
送出感谢: 0
接收感谢: 0

#4

帖子 xiulix » 2006-06-21 18:41

我是刚学ubutu您能说清楚一点吗?
谢谢!
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 huangjiahua » 2006-06-21 21:08

先试试
sudo dpkg --force-all -P cman fence clvm


可能这几个 打包有问题
跃过无数的时间断层,只为了在
ebridge2001
帖子: 20
注册时间: 2005-10-02 16:08
送出感谢: 0
接收感谢: 0

#6

帖子 ebridge2001 » 2006-06-29 22:33

(正在读取数据库 ... 系统当前总共安装有 111314 个文件和目录。)
正在删除 clvm ...
Stopping Cluster LVM Daemon invoke-rc.d: initscript clvm, action "stop" failed.
dpkg:处理 clvm (--purge)时出错:
子进程·pre-removal script·返回了错误号·1
Starting Cluster LVM Daemon clvmd could not connect to cluster manager
Consult syslog for more information
invoke-rc.d: initscript clvm, action "start" failed.
dpkg: 作下列清理工作时发生错误:
子进程·post-installation script·返回了错误号·3
dpkg:cman:有依赖问题,但是如您所愿还是继续删除:
fence 依赖于 cman (= 1.20060222-0ubuntu6).
正在删除 cman ...
正在清除 cman 的配置文件 ...
dpkg:fence:有依赖问题,但是如您所愿还是继续删除:
rgmanager 依赖于 fence (= 1.20060222-0ubuntu6).
正在删除 fence ...
正在清除 fence 的配置文件 ...
在处理时有错误发生:
clvm
头像
yang_hui1986527
帖子: 888
注册时间: 2006-03-04 23:10
来自: 江西高安
送出感谢: 0
接收感谢: 2 次
联系:

#7

帖子 yang_hui1986527 » 2006-07-04 13:11

cman
fence
clvm

应该是这几个 包的安装配置出了问题,删掉后重装这几个包!
QQ:273247606
EMAIL:yanghui1986527@gmail.com
turbohead
帖子: 58
注册时间: 2006-07-07 19:12
送出感谢: 0
接收感谢: 0

#8

帖子 turbohead » 2006-07-23 23:43

同样的问题,大家一起汇到这个帖子吧,看看有人能解决不
http://forum.ubuntu.org.cn/viewtopic.ph ... B%E7%A8%8B
imake
帖子: 60
注册时间: 2007-05-28 11:03
送出感谢: 0
接收感谢: 0

#9

帖子 imake » 2007-06-01 18:12

按楼上的帖子搞定了
tanjiashun
帖子: 1
注册时间: 2007-06-27 23:40
送出感谢: 0
接收感谢: 0

#10

帖子 tanjiashun » 2007-07-07 9:22

1.
$sudo rm /etc/init.d/clvm
2.
$sudo apt-get remove clvm -f --purge
回复

回到 “老旧版本支持”