当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : vi,gedit中文乱码,怎么办?
帖子发表于 : 2006-05-15 23:34 

注册: 2006-04-23 10:33
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
sudo dpkg-reconfigure locales
这个命令也不能设置什么啊,只是有这样的提示。


simon@Taliban:~/.fcitx$ sudo dpkg-reconfigure locales
Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
zh_CN.UTF-8... up-to-date
zh_HK.UTF-8... up-to-date
zh_SG.UTF-8... up-to-date
zh_TW.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Asia/Shanghai'.
Local time is now: 2006年 05月 15日 星期一 23:21:50 CST.
Universal Time is now: 2006年 05月 15日 星期一 15:21:50 UTC.
Run 'tzconfig' if you wish to change it.


还有locale是这样的

simon@Taliban:~/.fcitx$ locale
LANG=zh_CN:zh
LANGUAGE=zh_CN:zh:en_US:en
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=zh_CN.UTF-8

可是vi和gedit就是乱码。上次我还知道怎么设,这次就忘了。


附件:
Screenshot.png
Screenshot.png [ 227.91 KiB | 被浏览 2195 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-05-15 23:35 

注册: 2006-04-23 10:33
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
桌面那个htm文件的问号是原来就有的。跟这个没有关系。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-05-16 0:30 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
$ cat .vimrc
set fencs=utf-8,cp936
syntax on

gedit的不应该乱码。你看自己的.bash_history,看你作了什么


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-05-16 0:45 
头像

注册: 2005-10-25 11:15
帖子: 1016
送出感谢: 0 次
接收感谢: 1
Taliban......


_________________
hreiser@oakland:~$ killall -9 wife
police@oakland:~$ sudo find / -user hreiser
court@oakland:~$ sudo mv /home/hreiser /jail/
court@oakland:~$ sudo usermod -d /jail/hreiser -s "/usr/sbin/chroot /jail/" hreiser


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-05-16 8:14 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
laborer 写道:
Taliban......


怕怕. :roll: :roll: :roll: :roll:


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-05-16 9:24 

注册: 2006-05-16 9:23
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
谁在叫我?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: vi,gedit中文乱码,怎么办?
帖子发表于 : 2009-07-06 22:27 

注册: 2007-08-11 21:43
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
请问这么漂亮的桌面在哪儿找的,有1280*800的,不管有没有,请发我一份吧ximxom@163.com,非常感谢!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: vi,gedit中文乱码,怎么办?
帖子发表于 : 2009-07-07 0:04 

注册: 2008-04-30 12:34
帖子: 230
送出感谢: 0 次
接收感谢: 0 次
跟楼上同样的想法,这个桌面确实不错


页首
 用户资料  
 
9 楼 
 文章标题 : Re: vi,gedit中文乱码,怎么办?
帖子发表于 : 2011-05-06 14:29 
头像

注册: 2010-11-17 0:03
帖子: 150
地址: Bangalore, india.
送出感谢: 0 次
接收感谢: 0 次
gedit乱码问题解决:

按下 Alt-F2,打开“运行应用程序”对话框。
在文本框中键入“gconf-editor”,并按下回车键,打开“配置编辑器”。
展开左边的树节点,找到 /apps/gedit-2/preferences/encodings 节点并单击它。
双击右边的 auto_detected 键,打开“编辑键”对话框。
单击列表右边的“添加”按钮,输入“GB18030”,单击确定按钮。
列表的最底部新增加了一个“GB18030”。单击选中它,并单击右边的 “向上” 按钮直到 “GB18030” 位于列表的顶部为止。
单击确定按钮,关闭配置编辑器。 :em11


_________________
吃的苦中苦,方为人上人!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译