[问题]不能apt安装mplayer

为当前最终发行版之前的所有版本提供支持
回复
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

[问题]不能apt安装mplayer

#1

帖子 Beetle » 2006-05-21 21:30

apt装mplayer一直提示缺少包:

sudo apt-get install mplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer: 依赖: libfaac0 (>= 1.24clean) 但是它将不会被安装
E: 无法安装的软件包

我以为是缺少包,于是准备apt一个 libfaac0,但还是错误:
sudo apt-get install libfaac0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libfaac0: 依赖: libc6 (>= 2.3.6-6) 但是 2.3.6-0ubuntu19 正要被安装
E: 无法安装的软件包

当我装libc6时却说已经安装了:
sudo apt-get install libc6
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
libc6 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。

怎么会这样子?
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 Beetle » 2006-05-23 13:46

试着编译安装mplayer,按照论坛上的方法(无GUI),成功安装后却不能播放:
开始播放...
VDec: vo配置要求 - 512 x 384 (选择 csp: Planar I420)
无法找到匹配的色彩空间 - 重新尝试 -vf scale...
打开视频滤镜: [scale]
抱歉, 所选的视频输出设备与这个解码器不兼容.

致命错误: 无法初始化视频插件(-vf)或视频输出(-vo)!

Can't restore text mode: Invalid argument

正在退出... (文件结束)


这是什么原因??
aaronbai
帖子: 163
注册时间: 2006-10-15 10:12
送出感谢: 0
接收感谢: 0

#3

帖子 aaronbai » 2006-10-19 20:21

MPLAYER编译安装我还没成功呢!
回复

回到 “老旧版本支持”