求助:apt坏了

为当前最终发行版之前的所有版本提供支持
回复
kmt
帖子: 18
注册时间: 2006-05-12 9:39
送出感谢: 0
接收感谢: 0

求助:apt坏了

#1

帖子 kmt » 2006-05-23 12:54

系统是ubuntu dapper,前几天用apt装了latex-cjk等几个包,结果提示错误,后来就什
么软件都装/删不了了。错误提示:
E: /var/cache/apt/archives/latex-cjk-japanese_4.5.1+0.20030319-9ubuntu1_i386.
deb: 子进程·新的 post-removal 脚本·返回了错误号·1
E: /var/cache/apt/archives/latex-cjk-korean_4.5.1+0.20030319-9ubuntu1_i386.de
b: 子进程·新的 post-removal 脚本·返回了错误号·1
E: /var/cache/apt/archives/latex-cjk-thai_4.5.1+0.20030319-9ubuntu1_i386.deb:
子进程·新的 post-removal 脚本·返回了错误号·1

请问有没有办法修复,或者把错误的包删干净?
czopp
帖子: 161
注册时间: 2006-05-22 12:55
送出感谢: 0
接收感谢: 1 次

#2

帖子 czopp » 2006-05-24 1:36

可以尝试将以上几个包设置为hold吧
你装的是ubuntu库里面的包吗?
如果你的系统broken了,你可以启动synaptic看看,如果broken了
现修复broken,如果没有则hold那几个包,应该可以解决。
turbohead
帖子: 58
注册时间: 2006-07-07 19:12
送出感谢: 0
接收感谢: 0

#3

帖子 turbohead » 2006-07-24 0:00

同样的问题,大家一起汇到这个帖子吧,看看有人能解决不
viewtopic.php?t=20321&highlight=%E5%AD% ... B%E7%A8%8B
回复

回到 “老旧版本支持”