关于破损包如何处理?

为当前最终发行版之前的所有版本提供支持
回复
头像
oneleaf
论坛管理员
帖子: 10217
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

关于破损包如何处理?

#1

帖子 oneleaf » 2005-07-28 0:51

我安装了包,但在配置时出错了,于是我手工将安装好文件全部删除了。

这下糟了,

apt-get remove XXX 报错
apt-get -f remove XXX 报错
apt-get --reinstall install XXX 报错

都提示目录找不到,如何处理?
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
oneleaf
论坛管理员
帖子: 10217
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

#2

帖子 oneleaf » 2005-07-28 8:33

编辑 /var/lib/dpkg/status ,删除破损的包就好了。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yongyi » 2005-07-28 8:52

我倒在想,进入新立得,有个类别是破损的包(记不太清楚),然后从新立得里面删除,这不知道行不行。

再有个更笨的想法,重新再安装这几个包,然后再remove。

当然,最快就是修改记录已安装包的配置文件了(这也得知道才行 :wink: )。像叶兄你上面的一样。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
cscxk
帖子: 81
注册时间: 2005-06-29 22:14
送出感谢: 0
接收感谢: 0

#4

帖子 cscxk » 2005-07-28 13:18

干脆删掉全部的已下载内容
回复

回到 “老旧版本支持”