[问题]问题很严重,不能apt-get了

为当前最终发行版之前的所有版本提供支持
回复
头像
HYBOO_QIU
帖子: 84
注册时间: 2005-12-05 14:52
送出感谢: 0
接收感谢: 0

[问题]问题很严重,不能apt-get了

#1

帖子 HYBOO_QIU » 2006-05-25 18:52

我要升级,但是说我
-----------------------
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
acroread-plugins: 依赖: acroread (= 7.0.1-0.0.ubuntu1) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
--------------------------
我按照他的那么办,但是有报错
-----------------------------------------
(正在读取数据库 ... 系统当前总共安装有 93943 个文件和目录。)
正在解压缩 acroread (从 .../acroread_7.0.1-0.0.ubuntu1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/acroread_7.0.1-0.0.ubuntu1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/share/applications/AdobeReader.desktop”,它属于软件包 adobereader-chs
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
在处理时有错误发生:
/var/cache/apt/archives/acroread_7.0.1-0.0.ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
------------------
我remove adobereader-chs又显示
--------------------
下列的软件包有不能满足的依赖关系:
acroread-plugins: 依赖: acroread (= 7.0.1-0.0.ubuntu1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
-------
我该怎么办?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-05-25 20:10

把 acroread-plugins也卸载掉。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
HYBOO_QIU
帖子: 84
注册时间: 2005-12-05 14:52
送出感谢: 0
接收感谢: 0

#3

帖子 HYBOO_QIU » 2006-05-25 20:39

呵呵,搞定了。
shrimpy
帖子: 40
注册时间: 2006-05-24 19:22
送出感谢: 0
接收感谢: 0

#4

帖子 shrimpy » 2006-05-26 17:12

$ sudo dpkg -i --force-all /var/cache/apt/archives/acroread_7.0.1-0.0.ubuntu1_i386.deb

试试这个。。。强装
回复

回到 “老旧版本支持”